Cacti and ISPConfig: Monitoring Tool

Discussion in 'Tips/Tricks/Mods' started by VMartins, Nov 25, 2006.

  1. VMartins

    VMartins New Member

    Hello All,

    This topic is for anyone that have some questions, suggestions or comments about the How To:
    Cacti On An ISPConfig Server Within 10 Easy Steps - http://www.howtoforge.com/cacti_ispconfig.

    Thanks,

    Vinicius
     
  2. wmunguiam

    wmunguiam New Member

    Something is wrong!

    Hello,
    I use tutorial http://www.howtoforge.com/cacti_ispconfig

    On ISPConfig I created a Site CACTI, in OPTIONS I ADDED a Database with database name: web1_db1 and user: web1_u1, then I download Cacti package and Installed and I had a problem in Step 4:

    Step 4 - Setup the Cacti database:
    Create the MySQL database (If you prefer, you can use the PHPMyAdmin):
    sudo mysqladmin --user=root
    Import the default cacti database:
    sudo mysql web1_db1 < cacti.sql

    and it is the response:

    noc@manager:/var/www/web1/web$ sudo mysqladmin --user=web1_u1
    mysqladmin Ver 8.41 Distrib 5.0.24a, for pc-linux-gnu on i486
    Copyright (C) 2000 MySQL AB & MySQL Finland AB & TCX DataKonsult AB
    This software comes with ABSOLUTELY NO WARRANTY. This is free software,
    and you are welcome to modify and redistribute it under the GPL license

    Administration program for the mysqld daemon.
    Usage: mysqladmin [OPTIONS] command command....
    -c, --count=# Number of iterations to make. This works with -i
    (--sleep) only.
    .....
    .....

    --shutdown_timeout=#

    Variables (--variable-name=value)
    and boolean options {FALSE|TRUE} Value (after reading options)
    --------------------------------- -----------------------------
    count 0
    force FALSE
    compress FALSE
    character-sets-dir (No default value)
    default-character-set (No default value)
    host (No default value)
    port 3306
    relative FALSE
    socket /var/run/mysqld/mysqld.sock
    sleep 0
    ssl FALSE
    ssl-ca (No default value)
    ssl-capath (No default value)
    ssl-cert (No default value)
    ssl-cipher (No default value)
    ssl-key (No default value)
    ssl-verify-server-cert FALSE
    user web1_u1
    verbose FALSE
    vertical FALSE
    connect_timeout 43200
    shutdown_timeout 3600

    Default options are read from the following files in the given order:
    /etc/mysql/my.cnf ~/.my.cnf /etc/mysql/my.cnf
    The following groups are read: mysqladmin client
    The following options may be given as the first argument:
    --print-defaults Print the program argument list and exit
    --no-defaults Don't read default options from any options file
    ....
    ....

    variables Prints variables available
    version Get version info from server
    noc@manager:/var/www/web1/web$ sudo mysql web1_db1 < cacti.sql
    -bash: cacti.sql: Permission denied
    noc@manager:/var/www/web1/web$

    What is the problem?? Why I can't import database cacti.sql to web1_db1??
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Does your MySQL database have a username and password? have a look here: http://www.howtoforge.com/faq/6_4_en.html
     
  4. wmunguiam

    wmunguiam New Member

    you right my friend...

    I forgot write -u and -p

    thanks!!
     
  5. ocweb

    ocweb New Member

    Install on Centos5

    Hope I am in the right spot to post questions on the HowTo....

    I installed Cacti following the tutorial with the following differences;

    Centos5 install as per howto.

    1. Installed the repo/yum version of Cacti without downloading the version as described.
    2. Copied the contents of Cacti under /var/www to the web folder.
    3. Created a sub-domain (co-domain) for xzy.com to give cati.xyz.com.
    4. Made permissions for the web folder install (cacti folder) the same as the user.

    I followed all the other install directives with db/config/ etc.

    The problem I have is the cacti.xzy.com url returns a 403 error. i have a webmail.xyz.com co-domain and it is fine. I have set up Cacti the same way. Permissions are the same.

    To test, I have a simple html page and even with a direct request I get the same error.

    I am a little bit lost as to repair this issue.

    Thanks.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in Apache's error log?
    What's the output of
    Code:
    ls -la /var/www
    ?
     
  7. ocweb

    ocweb New Member

    Thanks for the help..

    The /etc/httpd/log/error.log contains this running from when I tried to configure Cacti;


    [Tue Jun 19 21:53:31 2007] [error] an unknown filter was not added: PHP
    [Tue Jun 19 21:53:31 2007] [error] an unknown filter was not added: PHP
    [Tue Jun 19 21:53:41 2007] [error] an unknown filter was not added: PHP
    [Tue Jun 19 21:53:41 2007] [error] an unknown filter was not added: PHP

    This runs on the same 10 second interval fom Sunday....

    Perhaps related to....

    Rather than Centos syntax?

    The code ls -la /var/www gives user names and sites with permissions and the only cacti related entry is;

    drwxr-xr-x 11 root root 4096 Jun 17 21:57 cacti

    I would have posted the lot but I am a forum nube and couldn't work how to get the code box?!!!
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Take a look here: http://www.howtoforge.com/forums/showthread.php?t=2165&highlight=$go_info["server"]["apache2_php"]
     
  9. ocweb

    ocweb New Member

    Thanks Falco, that repaired the recurring entry in the log.

    I have seen the Cacti howto on Centos4 on this Site. Am I better to use the package manager to remove Cacti and undo the manual modifications and try that method.

    OR.....

    Not too proud to admit defeat when it is a production server. I have a mind to replicate the server with another box as a backup and I can use that as the test bed for the Cati install.

    Should, from the poor description of what I have tried, be worried about any other items left by my attempt. I have already removed the inputted line from /etc/crontab.

    Can I thankyou and all involved in this Site for all the help that you give and the great package that Ispconfig is. I had a failing server with another Panel installed and I found this one awesome. I am sleeping at night now..hahaha.:)
     
  10. arevelo

    arevelo New Member

    Cacti No Works

    PLEASE HELP

    I INSTALLED CACTI BUT WHEN I TRY TO DO GRAPH ON DEBUG MODE ALWAYS SHOWS THIS MESSAGE:

    RRDTOOL SAYS:
    error: opening '/opt/lampp/htdocs/cacti/switch_cpu_11.rrd'; NO SUCH FILE OR DIRECTORY


    WHAT CAN I DO?

    TKS
     
  11. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /opt/lampp/htdocs/cacti
    ?
     
  12. arevelo

    arevelo New Member

    cati no works 2

    this is the output of it:
    [root@localhost cacti]# ls -al /opt/lampp/htdocs/cacti
    total 1096
    drwxr-xr-x 11 adi users 4096 ene 17 2007 .
    drwxr-xr-x 5 nobody root 4096 ago 7 18:45 ..
    -rw-r--r-- 1 adi users 5892 ene 17 2007 about.php
    -rw-r--r-- 1 adi users 4773 ene 17 2007 auth_changepassword.php
    -rw-r--r-- 1 adi users 6203 ene 17 2007 auth_login.php
    -rw------- 1 adi users 170951 ene 17 2007 cacti.sql
    -rw-r--r-- 1 adi users 13108 ene 17 2007 cdef.php
    -rwxrwxrwx 1 adi users 17023 ene 17 2007 cmd.php
    -rw-r--r-- 1 adi users 5917 ene 17 2007 color.php
    -rw-r--r-- 1 adi users 2846 ene 17 2007 copy_cacti_user.php
    -rw-r--r-- 1 adi users 18387 ene 17 2007 data_input.php
    -rw-r--r-- 1 adi users 28762 ene 17 2007 data_queries.php
    -rw-r--r-- 1 adi users 45400 ene 17 2007 data_sources.php
    -rw-r--r-- 1 adi users 31307 ene 17 2007 data_templates.php
    drwxr-xr-x 5 adi users 4096 ene 17 2007 docs
    -rw-r--r-- 1 adi users 6110 ene 17 2007 gprint_presets.php
    -rw-r--r-- 1 adi users 3423 ene 17 2007 graph_image.php
    -rw-r--r-- 1 adi users 10572 ene 17 2007 graph.php
    -rw-r--r-- 1 adi users 6502 ene 17 2007 graph_settings.php
    -rw-r--r-- 1 adi users 12446 ene 17 2007 graphs_items.php
    -rw-r--r-- 1 adi users 30927 ene 17 2007 graphs_new.php
    -rw-r--r-- 1 adi users 48109 ene 17 2007 graphs.php
    -rw-r--r-- 1 adi users 10097 ene 17 2007 graph_templates_inputs.php
    -rw-r--r-- 1 adi users 17367 ene 17 2007 graph_templates_items.php
    -rw-r--r-- 1 adi users 23468 ene 17 2007 graph_templates.php
    -rw-r--r-- 1 adi users 23261 ene 17 2007 graph_view.php
    -rw-r--r-- 1 adi users 35150 ene 17 2007 host.php
    -rw-r--r-- 1 adi users 15014 ene 17 2007 host_templates.php
    drwxr-xr-x 2 adi users 4096 ene 17 2007 images
    drwxr-xr-x 5 adi users 4096 ago 7 19:24 include
    -rw-r--r-- 1 adi users 2271 ene 17 2007 index.php
    drwxr-xr-x 2 adi users 4096 ene 17 2007 install
    drwxr-xr-x 3 adi users 4096 ene 17 2007 lib
    -rw-r--r-- 1 adi users 15141 ene 17 2007 LICENSE
    drwxr-xr-x 2 adi users 4096 ago 9 09:55 log
    -rw-r--r-- 1 adi users 1796 ene 17 2007 logout.php
    -rw-r--r-- 1 adi users 4462 ene 17 2007 poller_commands.php
    -rw-r--r-- 1 adi users 2399 ene 17 2007 poller_export.php
    -rwxrwxrwx 1 adi users 9314 ene 17 2007 poller.php
    -rw-r--r-- 1 adi users 4417 ene 17 2007 poller_reindex_hosts.php
    -rw-r--r-- 1 adi users 71 ene 17 2007 README
    -rw-r--r-- 1 adi users 4244 ene 17 2007 rebuild_poller_cache.php
    drwxr-xr-x 5 adi users 4096 ene 17 2007 resource
    drwxr-xr-x 2 adi users 4096 ago 8 15:59 rra
    -rw-r--r-- 1 adi users 7236 ene 17 2007 rra.php
    drwxr-xr-x 2 adi users 4096 ene 17 2007 scripts
    -rw-r--r-- 1 adi users 7363 ene 17 2007 script_server.php
    -rw-r--r-- 1 adi users 353 ene 17 2007 script_server.pl
    -rw-r--r-- 1 adi users 5148 ene 17 2007 settings.php
    -rw-r--r-- 1 adi users 6813 ene 17 2007 templates_export.php
    -rw-r--r-- 1 adi users 5954 ene 17 2007 templates_import.php
    -rw-r--r-- 1 adi users 17958 ene 17 2007 tree.php
    -rw-r--r-- 1 adi users 28925 ene 17 2007 user_admin.php
    -rw-r--r-- 1 adi users 35851 ene 17 2007 utilities.php

    I have some questions

    I found the problem but I don't know how to resolve it. When I create a new graph in cacti on debug mode the last line of rrdtool's commands comes with an extra slash "\" that's the reason why when cacti tries to search rdd file, it doesnt find it. If i run the same comands without this "\" from CLI, the file is created and cacti shows me the graph.

    #rrdtool create \
    /opt/lampp/htdocs/cacti/rra/test.rrd \
    -s 300 \
    DS:escritorio:GAUGE:600:-10:60 \
    DS:exterior:GAUGE:600:-10:60 \
    RRA:AVERAGE:0.5:1:600 \
    RRA:AVERAGE:0.5:6:700 \
    RRA:AVERAGE:0.5:24:775 \
    RRA:AVERAGE:0.5:288:797 \
    RRA:MIN:0.5:1:600 \
    RRA:MIN:0.5:6:700 \
    RRA:MIN:0.5:24:775 \
    RRA:MIN:0.5:288:797 \
    RRA:MAX:0.5:1:600 \
    RRA:MAX:0.5:6:700 \
    RRA:MAX:0.5:24:775 \
    RRA:MAX:0.5:288:797 \ this is extra slash that don't let to create .rrd file
    I dont want to create this file manually forever
    now the question is : how can i remove this slash from cacti ?

    The second questions is
    how can I check if my poller.php is working? 'cause i run poller from cli and I don't have any answer It only shows me this:
    [root@localhost cacti]# php poller.php
    Content-type: text/html
    X-Powered-By: PHP/4.3.9

    I think this is the reason why my graph doesn't show me any data

    thanks again
    sorry: !!my english is not very good lucky!! (celia cruz) :D
     

Share This Page