CA path error, file does not exist:admin/openssl.cnf

Discussion in 'Installation/Configuration' started by bch, Oct 31, 2013.

  1. bch

    bch New Member


    I'm on ISPConfig and Debian 7.

    I have a website on with a working trusted SSL configuration.

    I wanted to redirect to so I went to the redirect tab and
    set SEO Redirect to www.domain.tld => domain.tld even though I was unsure if it would work that way.

    Afterwards I got this error in the ISPConfig Log:

    CA path error, file does not exist:admin/openssl.cnf still worked with SSL. But not the redirection.

    I changed the redirect back to No redirect and got the same error again, but everything works as normal.

    What is the proper way of doing such a redirection? Via subdomain or aliasdomain?

    Last edited: Oct 31, 2013
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    If you have set up the "" as a website, then the best way would be to set "auto-subdomain" setting to "www" and then select the seo redirect www -> no-www

    But I'm not sure, if that solves your "error message" issue.
  3. bch

    bch New Member

    Thank you for your answer Croydon.

    I'll just clarify for the record.

    The redirect didn't work at first because I forgot to set up DNS (doh). Afterwards it worked.

    It seems that I got the error everytime I change a setting on that website. Fx. changing the auto-subdoman.

    It doesn't bother me too much. Apparently it doesn't break anything.
  4. labsy

    labsy New Member

    Interesting... lately I started receiving exact the same error:
    ERROR - CA path error, file does not exist:admin/openssl.cnf
    Seems like it is thrown every time someone changes anything in ISPConfig.

    It started when I upgraded a bunch of stuff, among them most significant change was MySQL from 5.1 --> 5.5. I also added PHP-FPM 4.3.x, but could not get it into work on this server (simply, web sites do not pick-up this PHP version, but runs on FastCGI).
    Also from above mentioned upgrades ISPConfig pops-up a warning
    The page at says:
    The changed data on this page will be lost if you press OK. Discarded if you press Cancel
    ...but nothing is changed, not even touched on the main Web Site page settings.

    Those seems to be related with ERROR - CA path...

    At least it is annoying receiving this error 20-times a day.
    Any idea how to approach?
    Last edited: Dec 4, 2013
  5. willieram

    willieram New Member

    I am also getting the same error, under Ubuntu 12.04.3 LTS , on the ISPConfig log.
  6. Blaasbalg

    Blaasbalg Member

    I was experiencing the same issue, untill I found out what was causing it for me.

    I was using Firefox while I was working in the ISPConfig panel, and when I logged in with the admin account, I clicked on 'Remember my password' when Firefox asked me to.

    Later I changed some settings in the Web tab of the server configuration, and it turns out that Firefox automatically filled the 'CA path' and 'CA passphrase' fields under 'SSL Settings' with the admin account details (due to the fact that I saved the login details in Firefox).

    After I cleared those two fields, the error disappeared. I obviously don't know if this is the same case for you guys, but it might be worth to check it. ;)
    Last edited: Dec 26, 2013
  7. willieram

    willieram New Member

    Dear Blaasbalg, that was precisely it! Tks so much!!!
    Happy New Year!
  8. tfboy

    tfboy Member

    Same thing here. Thanks!
  9. arraken

    arraken Member HowtoForge Supporter

    Had the exact same error, but with google chrome. Is this a bug that should be fixed in the ISPConfig interface? I found the solution quickly thanks to this thread, so it's not that bad, but i think that's something that will happen to many ISPConfig admins.
  10. jadik

    jadik New Member

    root cause is obscure

    wow... this problem of having server configuration fields auto-populate fields on the server configuration form seems like a good one to address.

    It seems unreasonable to have these two (hidden) fields auto-populate when changing other information on the server config... it should be easy enough to change the text-field names without causing any further programmatic tragedy, right?
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats already fixed for quite some tim in the git stable branch, see bugtracker.
  12. sghazagh

    sghazagh New Member

    I still experiencing this in ISPConfig 3.1b1 and solution provided above was working.
    It's good to check if this problem has been fixed and the fix has been merged to master in GIT.

  13. loeffel

    loeffel New Member

    Could somebody point out where exactly these two fields are?
    I can't find anything at System ->Serverconfiguration -> Web ->SSL Settings
    Last edited: Aug 26, 2016
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    System > Server Config > Web > SSL Settings: CA-Path and CA Passphrase.
  15. loeffel

    loeffel New Member

    till, that's exactly where I looked but all I see are two checkboxes - no hidden inputs either.
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    See screenshot. This is on apache with ispconfig 3.1, the fields exist in the same place on ispconfig 3.0.5.x as well.

    Attached Files:

  17. loeffel

    loeffel New Member

    I already contacted my hoster, seems I don't have permission to set this

    Attached Files:

Share This Page