Bypass amavis checks for outbound mail

Discussion in 'HOWTO-Related Questions' started by Manuel, Oct 16, 2009.

  1. Manuel

    Manuel New Member

    Hi all,

    My question has been previously discussed and solved in this forum and thread domains, only that it referred to debian sarge and I’m running debian etch by following Falko's tutorial at .

    The problem is the same one: I would like to disable amavis checks for outbound mail because the majority of my users use Outlook to send their mail and it get caught as spam because their machines Ips don’t have reverse resolution. The users don’t even know their mail don’t reach the destination!.

    As an example see the traces:

    Oct 16 10:17:05 correo amavis[7524]: (07524-04) Blocked SPAM, [] [] <[email protected]> -> <[email protected]>, quarantine: spam-7PoggwkEHEp6.gz, Message-ID: <[email protected]>, mail_id: 7PoggwkEHEp6, Hits: 7.631, 9226 ms

    Oct 16 11:37:28 correo amavis[6871]: (06871-07) Blocked SPAM, [] [] <[email protected]> -> <[email protected]>, quarantine: spam-mdG2M1gtj3YQ.gz, Message-ID: <[email protected]>, mail_id: mdG2
    M1gtj3YQ, Hits: 6.732, 17895 ms

    How could I make possible for the outbound messages to skip amavis check?

    Can anybody help?

  2. falko

    falko Super Moderator ISPConfig Developer

    The solution for Sarge should work on Etch as well, only that there's no single amavisd configuration file on Etch - the configuration is split up in several files in the /etc/amavis/conf.d directory, so you have to find the right one to place these lines.
  3. Manuel

    Manuel New Member


    I already did what you suggested in debian Sarge. I substituted in the conf file /etc/amavis/conf.d/05-domain_id

    @local_domains_acl = ( ".$mydomain" );


    @local_domains_acl = ( ".$mydomain" );
    read_hash(\%local_domains, '/etc/postfix/bypass_amavis_checks');

    being 'bypass_amavis_checks' a hash file with my listed domains and then I postmap it and restarted amavis, but it doesn't work.

  4. Manuel

    Manuel New Member


    I think I´ve come with a solution in the end:

    First I tried

    @local_domains_acl = ( ".$mydomain" );
    read_hash(\%local_domains, '/etc/postfix/virtual');

    being "virtual" the file postfix uses to know about virtual domains in the server but it didn´t work either.

    Finally I tried

    @whitelist_sender_acl = qw(list of domains);

    to turn off just spam checks (virus and banned extensions are still on) for locally originating mail, and it seems to work fine for all domains!

    Thanks for pointing me in the right direction!


Share This Page