building php 5.3.10 problem

Discussion in 'Server Operation' started by divine, Feb 28, 2012.

  1. divine

    divine New Member


    Trying to build php5.3.10 without success on lenny.
    Has anyone encountered such problem?

    :~/php-5.3.10# make

    /bin/sh /root/php-5.3.10/libtool --silent --preserve-dup-deps --mode=compile /root/php-5.3.10/meta_ccld -Iext/date/lib -Iext/date/ -I/root/php-5.3.10/ext/date/ -DPHP_ATOM_INC -I/root/php-5.3.10/include -I/root/php-5.3.10/main -I/root/php-5.3.10 -I/root/php-5.3.10/ext/date/lib -I/root/php-5.3.10/ext/ereg/regex -I/usr/include/libxml2 -I/root/php-5.3.10/ext/sqlite3/libsqlite -I/root/php-5.3.10/TSRM -I/root/php-5.3.10/Zend -D_REENTRANT -I/usr/include -g -O2 -fvisibility=hidden -pthread -DZTS -c /root/php-5.3.10/ext/date/php_date.c -o ext/date/php_date.lo
    In file included from /root/php-5.3.10/Zend/zend_config.h:1,
    from /root/php-5.3.10/Zend/zend.h:51,
    from /root/php-5.3.10/main/php.h:34,
    from /root/php-5.3.10/ext/date/php_date.c:21:
    /root/php-5.3.10/include/../main/php_config.h:2464:21: error: ieeefp.h: No such file or directory
    In file included from /root/php-5.3.10/main/php.h:34,
    from /root/php-5.3.10/ext/date/php_date.c:21:
    /root/php-5.3.10/Zend/zend.h:71:19: error: unix.h: No such file or directory
    make: *** [ext/date/php_date.lo] Error 1
  2. falko

    falko Super Moderator ISPConfig Developer

    It seems you need to install the packages...
    pocketpc-gcc and...

    ... one of the packages listed here:
  3. divine

    divine New Member


    thank you for reply.

    Yes, i understand what you mean:

    # dpkg -l|grep pocket
    ii pocketpc-binutils 2.15-2 The GNU binutils for Pocket PC
    ii pocketpc-gas The GNU assembler for Pocket PC
    ii pocketpc-gcc 3.4.2-2 The GNU C compiler for Pocket PC
    ii pocketpc-sdk 1.0.0-4 Pocket PC software development kit DL

    # dpkg -l|grep headers

    ii linux-headers-2.6.26-2-common-xen
    ii linux-headers-2.6.26-2-xen-686 2.6.26-27

    # dpkg -l|grep libgnet-dev
    ii libgnet-dev 2.0.8-1 Developer files for GNet network library


Share This Page