Build-Dep Failure

Discussion in 'Installation/Configuration' started by avaughan4, Dec 8, 2008.

  1. avaughan4

    avaughan4 New Member

    I am currently using "PHP 5.2.7-0.dotdeb.1" and when I try to run apt-get build-dep php5 the following is returned:

    apt-get build-dep php5
    Reading package lists... Done
    Building dependency tree... Done
    Package libmysqlclient14-dev is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
    E: Package libmysqlclient14-dev has no installation candidate
    E: Failed to satisfy Build-Depends dependency for php5: libmysqlclient14-dev

    I have removed libmysqlclient14-dev with --purge switch. I have installed libalps-heap1-dev. I have found some older deb sources to see if the dependency can be built from those. I have tried apt-get --fix-broken
    apt-get --ignore-missing

    Can someone help and let me know how to ignore the dependency or use the alternative libalps-heap1-dev to build-dep.

    Thank You.
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you install libmysqlclient15-dev instead and try again?

Share This Page