Bugs ISPConfig 2.2.21 !!!!!!!!!

Discussion in 'Installation/Configuration' started by misterm, Feb 14, 2008.

  1. falko

    falko Super Moderator ISPConfig Developer

    Hans was referring to my post, not to yours...
     
  2. falko

    falko Super Moderator ISPConfig Developer

    If you want mod_php5 for a web site when suphp is enabled in the overall ISPConfig configuration, please disable PHP for that web site in ISPConfig and add the following lines in the Apache Directives field:

    Code:
    <Directory /var/www/web1/web>
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode Off
    </Directory>
    BTW, are you sure that your solution worked prior to 2.2.20? Because the Apache Directives are written before all other directives, and if you disable suPHP in the Apache Directives, it gets enabled again later on because the suPHP directives are written after the Apache Directives.
     
  3. misterm

    misterm Member HowtoForge Supporter

    I will remove myself..., not?

    Hans, falko, Till, if you want that I remove myself, to remove my account, it is as you want, as that all the world will be count...., I am sad that that can this master key like that..., for a subject that the person have a difficulty which I had...

    :eek:

    MM
     
  4. edge

    edge Active Member Moderator

    I think that this is what they call miscommunication.

    misterm.. Mon ami. You really need to get a better France <> English translation program.
     
  5. SupuS

    SupuS Member HowtoForge Supporter

    Hi Falko

    Yes. I am sure it worked before 2.2.20 version. In 2.2.17 in vhost is:

    Code:
    <VirtualHost ***********:80>
    suPHP_Engine off
    RemoveHandler .php
    php_admin_flag engine on
    ServerName test.server.cz:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web1/web
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    suPHP_Engine on
    suPHP_UserGroup web1test1 web1
    AddHandler x-httpd-php .php .php3 .php4 .php5
    suPHP_AddHandler x-httpd-php
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    </VirtualHost>
    As you said .. apache additional directives are before other directives but it works. I am pretty sure because I use it very often.

    @misterm: Do you know somebody who can help you with English? Because your English is really horrible .. worse than mine and it is bad .. for everybody will be better if you will find somebody better in English than your translator ;)

    EDIT: Yes! Your sollution works. Thanks a lot Falco :D
     
    Last edited: Feb 18, 2008
  6. misterm

    misterm Member HowtoForge Supporter

    No, I do not speak English, in advance, then, is I use, babelfish as translator...

    ;)

    MM

    Explain me, why my 2 bonds are different, why, I have find the solution...
     
    Last edited: Feb 18, 2008
  7. daveb

    daveb Member

    I believe I am following you now falko after comparing old vs new vhost.conf

    old:
    Code:
    ErrorLog /var/www/web?/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    suPHP_Engine on
    suPHP_UserGroup web?_web web?
    AddHandler x-httpd-php .php .php3 .php4 .php5
    suPHP_AddHandler x-httpd-php
    Alias /error/ "/var/www/web?/web/error/"
    
    new:
    Code:
    ErrorLog /var/www/web?/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    [COLOR="Red"]<Directory /var/www/web?/web>[/COLOR]
      suPHP_Engine on
      suPHP_UserGroup web?_web web?
      AddHandler x-httpd-php .php .php3 .php4 .php5
      suPHP_AddHandler x-httpd-php
      SetEnv php_safe_mode On
    [COLOR="Red"]</Directory>[/COLOR]
    Alias /error/ "/var/www/web?/web/error/"
    
    So now to use mod_php5 if needed I will have to disable php for site so that suphp isn't added to vhost then add to apache directives to activate mod_php for web.
    Code:
    <Directory /var/www/web?/web>
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode Off
    </Directory>
    Thanks
     
  8. falko

    falko Super Moderator ISPConfig Developer

    That's really strange. :confused:
     
  9. falko

    falko Super Moderator ISPConfig Developer

    No, we don't want to remove your account, but please try to be polite to the other users of this forum.
     
  10. misterm

    misterm Member HowtoForge Supporter

    OK Falko , For the respect...

    OK, falko, I believe that this topics is regulated except if one among you do not have to find, but well quickly version 2.2.22, with, is I would like to know if it is possible for you, to add packages of installation, like joomla or typo3, that + for ISPConfig, I would be one believe..., that would give ideas for others, but Falko, I were with two fingers to do it, to remove me, but thank you for tone supports.... MM

    :eek: ;)
     
  11. Hans

    Hans Moderator ISPConfig Developer

    @Falko,

    Thanks for your answer, i will give your solution a try to see if it will work.

    I like suphp for a lot of reasons and for this reasons, i use it as my global setup for ispconfig. But i am really sure, that i could disable suphp, for those cases i needed php5mod instead. From ispconfig 2.2.20 i could not do that anymore. I am so sure, that i even mentioned it within my howto here: http://www.howtoforge.com/suphp_debian_etch_ispconfig. This also means that i have to change my howto.
     
    Last edited: Feb 19, 2008
  12. misterm

    misterm Member HowtoForge Supporter

    php5-cgi

    If you know suphp, Hans, you must know it well, then why, when it east put php5-cgi in the phpinfo is all in bottom, it to always mention php4, it is possible of the mêttre all in php5 in the phpinfo

    MM;)
     
  13. daveb

    daveb Member

    WOW misterm you just dont give up.
     
  14. falko

    falko Super Moderator ISPConfig Developer

    I wonder if the <Directory> directives that we wrap around the suPHP section in the vhosts since 2.2.20 are the reason that the old solution doesn't work anymore... Really strange...
     
  15. Hans

    Hans Moderator ISPConfig Developer

    @Falko,
    For me it's really strange too and it's the reason for me i reported about this problem. Now i have php5-cgi+suphp as my global php configuration again and for the sites which need php5mod, i can make use of your solution. Thanks for your help.
     
  16. misterm

    misterm Member HowtoForge Supporter

    Is yes Hans

    Hans, you speaks with whom, with me or in Falko, on the subject, it alone question that I pose to you, is you on which version of ISPConfig..., because I also made modif in the compilation of apache, from the point of view of the "suexec"...., is an E compilation of suphp as in the howto of Falko....

    http://www.howtoforge.com/suphp_debian_etch_ispconfig

    :rolleyes: ;)
     

Share This Page