Bug? Too many redirections errors after disabling SSL

Discussion in 'ISPConfig 3 Priority Support' started by chico11mbit, Nov 4, 2016.

  1. chico11mbit

    chico11mbit Member HowtoForge Supporter

    Hi,
    i think i found a bug in ISPCONFIG 3.1.
    When i enable SSL for a site and make then a check at "Rewrite HTTP to HTTPS" in the redirect Tab all is fine.

    1.) when i disable SSL for the site in the Domain Tab there appears an error in all browsers with "too many redirects".

    2.) When i disable "Rewrite HTTP to HTTPS" in the Redirect Tab before i disable SSL in the Domain TAB all is fine.

    I think the redirect SSL code is written in the vhost file in scenario 1 what shouldn't happen then.

    Here is the part in the vhost-file which is created with disabled SSL (scenario 1). but unchecked Rewrite rule HTTP to HTTPS. (the button is then hidden in the interface).
    It is not written in Scenario 2 which is fine.

    Code:
            RewriteEngine on
            RewriteCond %{REQUEST_URI} ^/\.well-known/acme-challenge/
            RewriteRule ^ - [END]
            RewriteCond %{HTTPS} off
                    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    
     
  2. chico11mbit

    chico11mbit Member HowtoForge Supporter

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The SSL code and redirect code is independent from each other. As an admin you have to ensure to not set a condition that can never met and a redirect from HTTP to https makes no sense when you don't have https. I will add a feature request to disable the redirect when someone disables SSL for a website.
     
  4. chico11mbit

    chico11mbit Member HowtoForge Supporter

    Hi Till,
    That would be very good. Sometimes customers do not know what is the right strategy to disable SSL. (First disable redirect, than SSL).
     
    nokia80 likes this.

Share This Page