Bug or User Error ?

Discussion in 'Installation/Configuration' started by linickx, Oct 23, 2006.

  1. linickx

    linickx New Member

    Hi All,

    A bit of a story, but hopefully it makes sense. I installed ISPConfig, one customer (me) created one website (www.linickx.com), placed a few php files and began testing.

    I then realised that my website is heavily customized, so thought it would be a good idea to set up sites for "default installs" of the apps I use.

    word.linickx.com = wordpress
    gallery.linickx.com = gallery
    etc,

    What I have found is the administrators of each site cannot log into e-mail. the admin "word" for word.linickx.com, with word@linickx.com cannot login, but the administrator for www.linickx.com can. (The same experience is the same for gallery, etc.)

    What makes it odd, if under www.linickx.com (the 1st site I created) I add a new e-mail address something@linickx.com that user can log in.

    So what do you think ? Should my admin's be able to get e-mail, or have I missed something - yes I've ticked the "mail user login" box :p

    Cheers,
    Nick
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    grep word.linickx.com /etc/passwd

    With which service do you try to connect, FTP, SMTP, POP3, IMAP, SSH?
     
  3. linickx

    linickx New Member

    Hi Till,

    I'm using the "web mail" thing, so what's that IMAP ? anyway, that user doesn't exist....

    Code:
    [root@linickx etc]#
    [root@linickx etc]# grep word.linickx.com /etc/passwd
    [root@linickx etc]#
    
    rgds,
    Nick
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log? What's the output of
    Code:
    grep word /etc/passwd
    ?
     
  5. linickx

    linickx New Member

    Hi Falko,

    Code:
    [root@linickx log]# grep word /etc/passwd
    web4_word:x:10003:10004:wordpress:/var/www/web4:/bin/false
    [root@linickx log]#
    
    ok, this is what I've found... ftp works, the website works, ssh doesn't

    from /var/log/messages
    Code:
    Oct 21 04:35:44 linickx sshd(pam_unix)[995]: session opened for user web4_word by (uid=0)
    Oct 21 04:35:44 linickx sshd(pam_unix)[995]: session closed for user web4_word
    
    ..but I guess that's because the shell is /bin/false ? (I have ticked the shell access box & hit save)

    the e-mail I've been testing is the webmail (uebimiau), obviously that doesn't work, what's odd is neither does an SMTP session....

    Code:
    [root@linickx log]# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    220 linickx.com ESMTP Postfix
    helo
    501 Syntax: HELO hostname
    helo test.com
    250 linickx.com
    mail from:me@here.com
    250 Ok
    rcpt to:wordpress@linickx.com
    550 <wordpress@linickx.com>: Recipient address rejected: User unknown in local recipient table
    rcpt to:something@linickx.com
    250 Ok
    
    ..but notice how my "something" account does. What do you think ?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    There are 2 checkboxes that must be enabled! You must enable shell in the user settings too, not only in the website settings.
     
  7. linickx

    linickx New Member

    cool, ok done that, /etc/password looks better, still can't log in, and e-mail is still the same :(

    Code:
    [root@linickx log]#ssh web4_word@localhost
    web4_word@localhost's password:
    Last login: Sat Oct 21 04:35:52 2006 from localhost.localdomain
    Connection to localhost closed.
    [root@linickx log]# grep word /etc/passwd
    web4_word:x:10003:10004:wordpress:/var/www/web4:/bin/bash
    [root@linickx log]# tail /var/log/messages
    Oct 21 17:44:44 linickx ftp(pam_unix)[12869]: session opened for user web4_word by (uid=0)
    Oct 21 17:45:26 linickx sshd(pam_unix)[12927]: session opened for user web4_word by (uid=0)
    Oct 21 17:45:27 linickx sshd(pam_unix)[12927]: session closed for user web4_word
    
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    ssh web4_word
    instead of
    Code:
    ssh web4_word@localhost
    Which distribution do you use?
     
  9. linickx

    linickx New Member

    nice....ok, I don't get why...

    Code:
    [root@linickx log]# ssh -l web4_word localhost
    
    works when

    Code:
    [root@linickx log]# ssh web4_word@localhost
    
    doesn't since they're the same thing, but hey, it doesn't matter :) Right so that shows the user account works. Any idea's how I troubleshoot the e-mail thing ?
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    grep "wordpress@linickx.com" /etc/postfix/virtusertable
    ?
     
  11. linickx

    linickx New Member

    here u r ....

    Code:
    [root@linickx log]# grep "wordpress@linickx.com" /etc/postfix/virtusertable
    [root@linickx log]# grep word /etc/postfix/virtusertable
    wordpress@word.linickx.com    web4_word
    web4_word@word.linickx.com    web4_word
    testpress@word.linickx.com    web4_testpress
    web4_testpress@word.linickx.com    web4_testpress
    
    I'm confused !
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Please add a co-domain linickx.com (with empty host field!) to the website word.linickx.com.
     
  13. linickx

    linickx New Member

    Hey Till,

    Well that fixed it thank ! :) ISPConfig, didn't handle sub-domains quite how I expected, but at least it's all working.

    Please can you clarify my understanding... the first domain you create (one.com) get default addresses of email@one.com, if you create a sub domain (sub.one.com) they get default addresses of email@sub.one.com (even if the gui doesn't tell you this ;) ) if you want the sub domain to use the parent e-mail you have to add it in as a "co-domain".

    Thanks v.much.
    Nick
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats correct.
     
  15. linickx

    linickx New Member

    thank you. :)

    kind regards,
    Nick
     

Share This Page