Bug in ISPConfig controlpanel?

Discussion in 'Installation/Configuration' started by buzzy, May 12, 2009.

  1. buzzy

    buzzy New Member

    I have some trouble with the dns-editor in ISPConfig.

    When I try to add a MX-record (or CNAME-record) that points to another domain, it becomes wrong.

    Lets say I have a mail-server at mail.mainserver.com

    Then for my site-domain I want to setup a MX-record that points to that domain, like this:

    mydomain.com MX mail.mainserver.com

    I click on the add MX-button, then fill in:

    Hostname: [I leave this blank]
    Mailserver hostname: mail.mainserver.com

    But this creates something like this:

    mydomain.com MX mail.mainserver.com.mydomain.com

    I even tried using mail.mydomain.com and creating a CNAME, but this creates the same result:

    mail.mydomain.com CNAME mail.mainserver.com.mydomain.com

    Seems like it automaticly ALWAYS adds the ".mydomain.com" to the end?

    Am I doing something wrong or is this a bug?

    I use version
  2. rdv25772

    rdv25772 New Member

    Just a dot

    I think you need to add a dot behind the hostname of the mailserver. I have experience the same problem.

    You should fill in the next:
    Hostname: [I leave this blank]
    Mailserver hostname: mail.mainserver.com.

    Don't ask me why. I only noticed it when I added a MX record to my own site and when I could not send an email to that domain.
    Last edited: May 12, 2009
  3. buzzy

    buzzy New Member

    I actually tried that as well, but I will try it once again just to be sure.
    I will post again with the results.
  4. buzzy

    buzzy New Member

    Strange, but it worked now. :)

    Adding a dot is common, and I am 100% sure that I tried it.

    I guess I did not wait the minute it takes for ISPConfig to run the updates.

    Thank you anyways for pointing it out.

Share This Page