[bug] ftp login and no proper removal

Discussion in 'Developers' Forum' started by nikro, Dec 22, 2008.

  1. nikro

    nikro New Member

    Hello everybody,

    I added a new Customer, Web and a user for ftp usage, but logging in failed:
    Switching "/dev/null" to "/bin/false" in passwd makes the ftp-login possible.

    The second issue appeared when I deleated web9. The users aren't removed in the /etc/passwd and the htdocs-dir in /var/www does still exist, too..
    I had a look at the database and found this in del_status:
    Code:
    id 	doc_id 	doctype_id 	name 	    pfad 	                        web_host 	web_domain 	status
    3  	8       1014        web9_test   /var/www/web9/user/web9_test
    4 	9       1013        web9        /var/www/web9 	                www      	domain.com 	 
    5 	7       1014        web9_ftp    /var/www/web9/user/web9_ftp 	  	  	 
    6 	8       1014        web9_test   /var/www/web9/user/web9_test
    
    Is this normal? Should that be done already?

    The 3th and last thing is, that when I set the host of a web/domain to www, switch it to www2 and then switch it back to www ispconfig sais that "www" is already in use.

    All this things are reproduceable. I'm using ISPConfig-2.2.29 on Debian Etch


    Greetings
     
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Did you empty the recyclebin?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    /etc/passwd has never to be edited. Instaed you have to enable the FTP checkbox in the website settings.

    you have to empty the recycle bin if you want to recreate a site that you deleted before.
     
  4. nikro

    nikro New Member

    Shame on me, you're so right.. I was just over-worked and need the holidays now..

    So thanks for your help and your great and reliable doing on ISPConfig!

    Merry Christmas!
     

Share This Page