BUG counting reseller's databases

Discussion in 'Installation/Configuration' started by Davide, Jul 28, 2006.

  1. Davide

    Davide New Member HowtoForge Supporter

    Hi

    If I assign, for example, 20 databases to a reseller, he cannot create more than 20 sites, even without database. If you look at reseller's statistics, you can see:


    Users used: 20 of unlimited
    "Databases created: 0 of 20"

    but if reseller tries to create a new site, he gets the following message:

    "You have left only 0 database(s) which you can assign to this website."

    It doesn't matter if reseller allows sites to create DB or not. EVERY site counts as one database for the reseller.

    Thank you
     
    Last edited: Jul 28, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    We will check that.
     
  3. hamish

    hamish ISPConfig Developer ISPConfig Developer

    cant replicate bug in ver 2.3.1

    I have tried recreating this bug with Fedora Core 5, ISPConfig ver 2.3.1, MySQL 5.0.22 but could not get it to happen.

    I did following:
    - created new reseller (500MB disk space, unlimited bandwith, 2 MySQL databases)
    - created 6 new sites under reseller with varying amounts of disk space, DNS records but no databases enabled)

    worked correctly - no error messages. Stas summary shows 0 of 2 databases used.

    Also tried adding extra "A" DNS records to all sites - still no problems adding new sites.

    I have updated bugtracker with findings and set to resolved/works for me.
     
  4. Davide

    Davide New Member HowtoForge Supporter

    Hi

    I'm using ISPconfig 2.2.5 and it's allways reproductible.

    Might be it was corrected between these two versions?
     
  5. hamish

    hamish ISPConfig Developer ISPConfig Developer

Share This Page