Bug? Adding Apache Directive to Site Breaks ISPC3

Discussion in 'ISPConfig 3 Priority Support' started by Nilpo, Dec 9, 2013.

  1. Nilpo

    Nilpo Member HowtoForge Supporter

    Whenever I try to save an Apache directive to any site, it breaks ISPC3. The save operation does not complete successfully, and no change is made to the database. (It also breaks Javascript on the page, but I have not confirmed this in a console yet.) Reloading the page shows that Apache has crashed and any url results in the basic Apache page. Reloading Apache solves fixes the problem, but I cannot use any Apache directives from the Options tab of any site.

    This happens whether I add them directly or from a snippet. I have only tried this from Chrome on Backtrack 5R3. I will try attempt from other browsers on Windows tomorrow to verify it is not a browser issue.

    Is this a bug anyone else has come across?

    I'm running ISPConfig on CentOS 6.4 x64.


    I found the following in the Apache error log.
    [error] [client] client denied by server configuration: /var/www/ispconfig/sites/ajax_get_json.php, referer: https://mydomain.com:8080/
    Last edited: Dec 9, 2013
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This is most likely a issue with the apache directive and not with ispconfig as faulty apache directives can crash apache and as the ispconfig interface uses the same apache server then the websites, the ispconfig interface will become unavailable then as well.

    Which exact apache directive do you add?

    Is "Test apache configuration on restart" enabled under System > server config > web?
  3. Nilpo

    Nilpo Member HowtoForge Supporter

    Entering any text at all into that field breaks it. I tried several different directives and nothing worked. I even copied working ones out of the live httpd.conf file. I was trying to use this:

    <IfModule mod_geoip.c>
    	GeoIPEnable On
    	GeoIPDBFile /usr/share/GeoIP/GeoIP.dat
    	SetEnvIf GEOIP_COUNTRY_CODE CN BlockCountry
    	SetEnvIf GEOIP_COUNTRY_CODE RU BlockCountry
    	Deny from env=BlockCountry
    Test apache configuration on restart is enabled.
  4. Nilpo

    Nilpo Member HowtoForge Supporter

    I've done some more testing. I've managed to narrow this down to a problem with Chrome on Windows. Other browsers seem to work fine as does Chrome on Linux.

    It's very strange that is only happens on that textarea. The one right above it works just fine. I'll load up a Javascript console later and see if I can narrow down the issue.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    maybe you use any special plugins in chrome? I use chrome as my daily webbrowser on windows and dont have any problems with ispconfig.
  6. Nilpo

    Nilpo Member HowtoForge Supporter

    I used AdBlock and a few developer plugins. I'll try disabling them and see which one breaks it.

Share This Page