BUG: 2.2.7 - Editing Web as Admin - Domain is empty!

Discussion in 'General' started by Ben, Oct 18, 2006.

  1. Ben

    Ben ISPConfig Developer ISPConfig Developer

    After upgrading to 2.2.7 (from 2.2.6) I wanted to change the options of a web (adding safe_mode). After clicking to save it told me to enter the domain. I took a look to all webs, everywhere the field domain is emtpy!
    To not mess up the things I'd like to know if sb. else has the same problem.

    EDIT: The Problem is much bigger, even the user has no web, so ALL options are empty and I can do nothing!

    EDIT2: Ok it looks like the DB export was not imported after the upgrade, so can I savely load the old dump or will I mess up anything new?
    Last edited: Oct 18, 2006
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Importing the old dump does not help, flushing, importing the dbstructure from svn, importing the data from the old dump results in not finding any nodes in the interface... so anyhow I have to merge the old data to the new structure... any ideas?
  3. edge

    edge Active Member Moderator


    I've had a look at my system(s) (also updated from 2.2.6 > 2.2.7), but it does not look that I have that problem!

    Can you explain a bit more on what you did, so I can have an other go at it on my system, and see if I have the problem also.
  4. Ben

    Ben ISPConfig Developer ISPConfig Developer

    I just upgraded from 2.2.6 to 2.2.7 without any errors on the console....

    now I wanted to change the options in the web of one customer, but the thing is empty. Domain is missing as well as all other options.
    The same thing with all customers in the db.
    When I took a look in the DB itself, tables like isp_isp_user etc. are just empty so I guess some data is missing.
    So I tried to merge the old content to the DB (from the old dumps) but I got importerrors.
    So I created a fresh DB imported the structure from the ispconfig installzip, imported the dump from the upgrade backup. But then I could not really move in the admininterface because it told me some nodes etc. were not found.

    EDIT: Maybe sth. special in my structure, I put everything below the folder "customer". That means I create a folder "customername" below "customer". Inside customername there is the webentry as well as the basic customerentry... did this make a problem?

    EDIT2: One error e.g. when merging, if I flush all isp_isp tables and import their content from the backup from the upgrade, I get the error "nknown column 'user_emailweiterleitung_no_scan' in 'field list'"...
    Last edited: Oct 18, 2006
  5. edge

    edge Active Member Moderator

    I'm not having any problems like this with any of my updated server.

    My isp_isp_user:

    All the way down to:
    All other tables are also still okay.

    I do not know. Maybe wait till one of the experts reads this message....
    All I can say is that I do not have (thank God) this problem..
    OS: Debian Sarge

    Good luck!
    Last edited: Oct 18, 2006
  6. Ben

    Ben ISPConfig Developer ISPConfig Developer

    @edge: thx ;) I'm just happy to have the DB backup, the rest will get fine anyway.... the question is just, how to migrate the old DB (data + structure) to the new one.. then everything would be fine.

    EDIT: what's that, email_weiterleitung_noscan is even not defined in the db structure from 2.2.6, so does it remain from 2.2.5???
    EDIT2: ftp_user, user_emaildomain is also not in the structure, so can sb. tell me what happened here?

    EDIT3: OK I fixed the strcuture from the isp_isp_user dump... the problem is as above mentioned to merge old data with the new structure and taking care of the doctypes, because they are now broken when I merge Structure + Dump (from 2.2.6)
    Last edited: Oct 18, 2006
  7. Ben

    Ben ISPConfig Developer ISPConfig Developer

    After some time I solved it.
    Installed ISPConfig 2.2.6 freshly in a VMware. Imported the old dump (only the isp_ tables), but had to wipe out some columns that were no more used (like cyrus... or the mentioned above). Then checked if everythin generates fine and looks fine in the adminpage, upgraded to 2.2.7 (this time without errors ;) ) and copied that dump to the productive machine.

    I guess the upgrade failed because some tables could not be imported cause of that column mismatch.
    => @ TILL / FALKO: Maybe the dump shuld also dump the structure not only tables or do we get problems elswhere then?
  8. falko

    falko Super Moderator ISPConfig Developer

    We only need the data because the structure is included in the SQL dump that comes with the new ISPConfig version.
  9. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Well that's right, but I still wonder, why my dump from 2.2.6 contained fields, that did not match the structure of 2.2.7 :-\
  10. falko

    falko Super Moderator ISPConfig Developer

    Did you see any error messages during the update?

Share This Page