Browser downloads php file instead of showing me the web page

Discussion in 'Installation/Configuration' started by scenic2, Jul 14, 2013.

  1. scenic2

    scenic2 New Member

    Hello,

    In Ispconfig 3.0.5.2 on OpenSuse 12 with Apache I have the following problems:

    Problem 1.

    When i try to access
    http://www.mydomain.com/phpmyadmin
    or
    http://www.mydomain.com/webmail
    the browser is not showing anything and php file is downloaded (The "Save as" Window appear).
    The problem appeared after my first site was created. Before that everything was great.
    Any idea?

    Problem 2.

    On the address http://My_IP the browser return my first site (in alphabetical order, not web1)
    For this problem I found an answer here:

    http://www.howtoforge.com/forums/showthread.php?t=61991

    This is a solution but I don't think this is the best.


    My server was installed using this tutorial:
    http://www.howtoforge.com/perfect-server-opensuse-12.2-x86_64-apache2-dovecot-ispconfig-3
    EDIT: single server setup

    Thank You in advance!
     
  2. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    @Problem 2:
    This is the correct solution. You have to enable the default vhost and put your default site there.
     
  3. scenic2

    scenic2 New Member

    I think the problem is about permission of /srv/www/htdocs folder because I made an experiment:
    1. Moved folder phpMyAdmin inside to mydomain (/srv/www/clients/client1/web1/web),
    2. removed (comment) symlink from /etc/apcahe2/conf.d/phpMyAdmin.conf
    3. Trying to access www.mydomain.com/phpMyAdmin

    Everything was OK.

    So accesing php file from /srv/www/htdocs php script is not executed
    Accesing from /srv/www/clients/client1/web1/web everything is OK

    What's the problem? Anybody can help me?
    Thanks
     
    Last edited: Jul 16, 2013
  4. scenic2

    scenic2 New Member

    So, nobody knows?
     
  5. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I think php is not enabled in the main web directory /srv/www so it can not execute php scripts in there.
    If you need this you have to create the corresponding php settings for modphp, fcgi etc. in the default vhost.
     
  6. scenic2

    scenic2 New Member

    I don't know how to do that but i will google it first.
    Thanks
     
  7. scenic2

    scenic2 New Member

    Phpmyadmin or webmail is working fine only in mod-php mode.

    OK. I made another (little) step.

    Phpmyadmin or webmail is working fine only in mod-php mode.

    When I switch to Fast-CGI, CGI, Su-PHP, or PHP-FPM the appear.
    So, what should I do? What's the problem?
    Can You Help Me?

    Thank You!

    PS: At the time of installation I chose to change the ISPConfig listen port setting from 8081 (default) to 9091 (my custom port) for instance. Can this be the cause of my problems?
    I ask that because in /etc/apache2/sites-available/apps.vhost the port remain 8081 and changing to my new port 9091 apache failed to start.
     
  8. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The port 8081 is the apps vhost. (/var/www/apps)
    The port 8080 (or 9091 in your case) is only ISPConfig interface.
     

Share This Page