broken /var

Discussion in 'Technical' started by nox171, Mar 15, 2007.

  1. nox171

    nox171 New Member

    Ops I did it again!

    I was looking into a script. I was inside several folder... /var/www/webxx/...
    instead of
    rm -rf var
    I did
    rm -rf /var

    The / that makes the difference!! :eek:

    When I realized what I was doing it was to late!
    Most of the /var folder was gone!!!

    I have another server totally similar to this one:

    suse 10.0 with ISPconfig.

    I tried to restore the var folder from the live server but I still miss something!

    Is it possible to recover this sistem or is it to late??

    Now ispconfig is not working and I receive several error if I try to run Yast.

    Do you have any suggestion? Can I run some kind of utilities from the Suse dvd installation?

  2. falko

    falko Super Moderator ISPConfig Developer

    If the other system is identical, you could try to copy over the /var directory. Otherwise, a reinstall is the best option (unless you have a backup of the /var directory).
  3. nox171

    nox171 New Member

    Thanks Falco,

    I have backup of the site but not for all the /var directory.
    This week I'll do a complete reinstallation of the server.

    Is there a way to avoid something like that to happen again?

    Someone told me to type .var instead of simply var
    In this way the dot means from this folder, isn't it?
  4. brengo

    brengo New Member

    no, it would be ./var to indicate "the folder named var in this folder".

    Technically, the . means "this folder" and .. means "parent folder" (this is why "cd .." works) but .var would be a hidden file named .var and not the directory (remember: dot-files in unix/linux are hidden, a ls doesn't show them, only a ls -a)
  5. falko

    falko Super Moderator ISPConfig Developer

    The only thing you can do is create backups regularly.

Share This Page