Broke Server installing Postfix etc... HELP

Discussion in 'Installation/Configuration' started by skysober, Mar 12, 2009.

  1. skysober

    skysober New Member

    I was following this tutorial - and now anytime I try to install anything I get 'can not connect to database.

    I have webmin and virtualmin both installed, and ssh into the root... It is running "Debian GNU/Linux 4.0"

    I had Postfix and Dovecot all running, but never quite working, then tried the setup above and now have it totally fubar.

    my Sql and Apache does work, as one of my main sites I have on it is running still, but without any email capabilities.

    For a Linux idiot, is there any tutorial that can be followed that doesn't care if something has already been installed, but is quite probably installed incorrectly? I have tried the server support, but they say theirs are unmanaged dedicated servers, so I need to find my own help. My problem is I know enough about Linux to fit on the head of a needle, and everytime I search for clues to fix it, it just keeps getting more broke.

    Can anyone help me find how to get the email server working?
  2. falko

    falko Super Moderator ISPConfig Developer

    Are you referring to apt or MySQL?

    Do you have the possibility to restore a clean Etch image onto your server?
  3. skysober

    skysober New Member

    I can have it re-installed, at $69.... but I would loose about 18 gig of uploaded files - with the 7 sites I have already installed on there...

    And I wish I only knew what 'database' it can not connect to. It does it when I try to install anything now.

    I did get the postfix and dovecot re-installed and it says it is working according to webmin, but it isn't.

    Example I added an email account of "[email protected]", when I click on the view mailbox and select "joe" it will send out email using webmin, but it is not '[email protected]', it is '[email protected]" and I have tried setting up Outlook to send and receive using both 'names', yet nothing. I have tried replying to the sent email from '[email protected]" and it never shows up in the users mailbox in webmin...

    If you wish, I could PM you an ssh into the server to peek at it?
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log when you reply?

    Does the MX record for point to the right server? you can check that with
    dig mx
  5. skysober

    skysober New Member

    Domain Name Manager:

  6. skysober

    skysober New Member

    Looking at the Mail Queue: 495 messages

    Example message 000D5120D50:

    Eaxmple test using the forums software to send an email,
    message 076DB120E14:

  7. skysober

    skysober New Member


  8. falko

    falko Super Moderator ISPConfig Developer

    The MX record for is pointing to which is a CNAME record. But it must be an A record. Please fix that first before we proceed with the other problems.
  9. skysober

    skysober New Member

    okay... then I must not know how to proper set it... This is done in the domain name setup itself? where do I change it, to what?

    on a side note: if I even try to addusr joeblow now on the command line, it says "can not connect to database..." user not added.
  10. falko

    falko Super Moderator ISPConfig Developer

    Do you run your own nameservers, or do you use your registrar's nameservers? You can find that out with
    dig ns
  11. skysober

    skysober New Member

    I do not know how to set my own up... I read about it, and talk aboutconfusing! I even have two IP's on the server as I would like that option, but it was where I would just be happy to get the email working first...

    It is set at the way it always has been in the domain name thing. ( )

    Question, would I be able to let you into my server to look at it, and then of course you post here how I can fix it (so others can read and learn too,) without me trying to go back and forth and guess?
  12. falko

    falko Super Moderator ISPConfig Developer

    You can contact Till (info [at] projektfarm [dot] de) if you need support.
  13. skysober

    skysober New Member

    tried, but no reply to my email....
  14. falko

    falko Super Moderator ISPConfig Developer

    When did you send the mail? If it was on the weekend, it can take a little bit longer until you get a reply.
  15. skysober

    skysober New Member

    the 17th - same day you mentioned it. (I have email direct notification on here in this thread and it beeps my phone a notification even...)

    And I have stopped trying to fix it, as it seems to just get worse and break other things now - lol
  16. falko

    falko Super Moderator ISPConfig Developer

    We've just checked, and we didn't receive an email from you... Can you check if your mailserver is blacklisted?
  17. skysober

    skysober New Member

    uh yah, let me see... oh wait, how the heck would I do that? :confused: You guys are LIGHT years ahead in knowledge over me. I would say I can still lick a stamp and mail it, but they don't even do that anymore, it is already sticky - hehe

    And the email server is simply one of my hotmail accounts.
  18. falko

    falko Super Moderator ISPConfig Developer

    That might have been the problem...

Share This Page