Broke nginx with SSL configuration

Discussion in 'Server Operation' started by Vorvek, Feb 26, 2020.

  1. Vorvek

    Vorvek New Member

    Hello, I recently updated an ISPConfig installation for a client and when prompted I just created a new self-signed SSL certificate. Apparently, the client was using Let's Encrypt and now nginx won't start anymore. I've tried following the steps in this tutorial and now journalctl -xe gives me the following error:

    nginx: [emerg] SSL_CTX_use_PrivateKey_file("/usr/local/ispconfig/interface/ssl/ispserver.key") failed (SSL: error:2807106B:UI routines:UI_process:Processing error:while reading strings error:0906406D:PEM routines:PEM_def_callback:Problems getting password error:0906A068:PEM routines:PEM_do_header:bad password read error:140B0009:SSL routines:SSL_CTX_use_PrivateKey_file:PEM lib)
    I also tried running the update script again and ignoring the password field when prompted, but the error message stays the same in journalctl

    What should I do?

    Edit: Nevermind, I just noticed that the error was different after running the script, and commenting the certificates in the vhost for the admin site was enough to get nginx running again.
    Last edited: Feb 26, 2020

Share This Page