botting problem ubuntu 12.04

Discussion in 'Installation/Configuration' started by klamardo, Sep 30, 2014.

  1. klamardo

    klamardo New Member

    excuse the English translator.

    I am simulating a problem that I have noticed in several ubuntu 12.04 server with ispconfig
    I using / var as a separate partition have a problem with the montage of
    /var/log/ispconfig/httpd/$domain /var/www/clients/clientX/webY/log none bind,nobootwait,_netdev 0 0

    the server reaches the end of the boot partition is hoping that this prepared
    if I start the server with the option of rescue and give a few seconds before resuming normal .. the botting .. if I take the the /var/log/ispconfig/httpd/$domain

    or commented first or some work .. apparently is something out of ubuntu at least in assembling units now .. see you replicate the possible failure of a debian .. so far I have not had this kind of problem .. but I have several servers that have more than 1 year up .. and hundreds of domain ..mejor prevent ..

    update.
    without partition / var separate boot issue still going 3 of 4 trials.
    Common factor in proven cases.

    /var/log/ispconfig/httpd/$domain /var/www/clients/clientX/webY/log none bind,nobootwait,_netdev 0 0


    fix ... /etc/init/mountall.conf
    exec mountall --daemon $force_fsck $fsck_fix

    change
    sleep 15s && exec mountall --daemon $force_fsck $fsck_fix

    10 reboots flawlessly so far .. intrigued

    no one else has had this strange behavior in reboteos with ubuntu ispconfig server with many domains added in fstab?

    update 2.
    manuals fix did not resolve or give stability to start looking at ..
    https://launchpad.net/ubuntu/ source/mountall/2.36.4

    in https://launchpad.net/ubuntu/ source/mountall
    in my particular case
    https://launchpad.net/ubuntu/ archive/primary/ files/mountall_2.36.4_amd64.deb

    until after 40 starts has not been resubmitted failure

    All tests were done on a ubuntu 12.04 with updates per day
    end .. only difference was the installation of mountall 2.36.4 manually ( reinstall )
     
    Last edited: Oct 1, 2014
  2. klamardo

    klamardo New Member

    /var + mount bind ( fstab )

    definitely /var as a separate partition + bind mount (for ispconfig) unstable in boot .. bad combination in ubuntu 12.04 lts

    testing upgrade from 12.04.5 lts to 14.04.01 lts with ispconfig3 p3 + dkim 1.0 with /var separate one other settings more than anything in the apache
    works .. and no more problems start .. but of course the bug in 12.04. has like 3 years
     
    Last edited: Oct 3, 2014

Share This Page