Botched Install / Apache

Discussion in 'Installation/Configuration' started by 3DPeruna, Feb 24, 2012.

  1. 3DPeruna

    3DPeruna New Member

    I accidentally started down the NGINX path, got to the point where I had installed NGINX, then move to the Apache2 path running the Apache stuff. Eveything was fine.

    Then I installed an SSL certificate on a site. It botched things up so I uninstalled it. Botched things up so I couldn't get to the ISPconfig control panel.

    Now, I can't get Apache2 to restart. I've tried to remove Nginx, but when I reboot, it comes back. I kill the port, but Apache2 doesn't start. If I apt-get remove nginx, the first time, it was removed. Now, when I try to remove it, it Apt tells me it's not installed.

    There is nothing in the Apache2 error logs. I can't see anything in /var/log/syslog

    Apache2 won't restart...

    Code:
    [Thu Feb 23 17:00:48 2012] [warn] NameVirtualHost 69.168.254.124:80 has no VirtualHosts
    [Thu Feb 23 17:00:48 2012] [warn] NameVirtualHost 69.168.254.124:443 has no VirtualHosts
    [Thu Feb 23 17:00:48 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
    [Thu Feb 23 17:00:48 2012] [warn] NameVirtualHost 69.168.254.124:80 has no VirtualHosts
    [Thu Feb 23 17:00:48 2012] [warn] NameVirtualHost 69.168.254.124:443 has no VirtualHosts
    [Thu Feb 23 17:00:48 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
    
    Action 'start' failed.
    The Apache error log may have more information.
    
    
    Is all I get...

    Help?
     
  2. 3DPeruna

    3DPeruna New Member

    Fixed it...

    Found the problem with a botched SSL certificate. Got rid of it from the site.vhost file and all is well.
     

Share This Page