bootloader not installed with systemimager

Discussion in 'HOWTO-Related Questions' started by aqua, Sep 1, 2006.

  1. aqua

    aqua New Member

    I am trying to restore my system from a systemimager image, using the dedicated restore script. After the script finishes copying all the files it gives me this error and quits:

    Error: none of the following bootloaders wchere successfully setup on your system
    YaBoot, Iseries, EFI, Elilo, Grub, Palo, Aboot

    My setup:
    Knoppix live cd v5
    restoring to an external usb drive (my server is also running of an external usb drive with no internal drives, ubuntu dapper)

    I tried booting the restored image but its not bootable, though all my files are there.

    Any suggestions would be welcome :)

    -------------------
    Update:

    I just checked by /boot directory and found that i didn't have a /boot/grub directory ... which i found very odd... I remember a little while ago i tried to upgrade to the latest version of ubuntu by doing and apt-get dist-upgrade , which failed and gave me an error with grub. I think it is coming back to bite my in the rear. I don't even know how the server boots without a grub diretory! What can i do to fix this?
     
    Last edited: Sep 1, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    That sounds odd. You can try
    Code:
    apt-get install grub
    , but I think it's better to reinstall the system.
     
  3. aqua

    aqua New Member

    re-install the whole thing? os and ispconfig?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You can try my first suggestion, but if it doesn't work, it's less painful to reinstall everything instead of messing around with the system for days or even weeks.
     

Share This Page