Booting On PXE And On A Customized Debian System

Discussion in 'HOWTO-Related Questions' started by sebastienp, Mar 20, 2008.

  1. sebastienp

    sebastienp New Member

    Hi there,

    I already read something regarding the issue I experiment, but no acceptable answer was provided so I'm stuck in the fog.

    Once I followed your howto, I was unable, whatever I changed, to boot on the customized debian image. It's been close to 2 days I've been working on it, but it looks like it's impossible to get nfs work.

    Again, and again, and again the same error, as mentionned before, by other users, here and there around Google :
    nfs: server XXX not responding, still trying.

    I never saw a NFS OK in the logs, even if i can access nfs share with another computer.

    DHCP is OK (driver loaded, correct address and so on)
    TFTP is OK (as far as I can see)
    NFS is working (showmount -e localhost OK, and so on...),
    BUT IT'S NOT POSSIBLE TO BOOT on the customized system.

    Do someone have a clue ?
    Did it work for someone ?

    Regards,
    SP
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What tutorial (URL) are you using?
    Any errors in your logs?
     
  3. sebastienp

    sebastienp New Member

    Hi Falco,
    Thanks for your reply and support.

    I used this URL : http://www.howtoforge.com/pxe_booting_debian. I followed the howto stricly, except name and IP address.

    Here are my configuration files :
    /pxeroot/etc/network/interfaces
    # The loopback network interface
    auto lo
    iface lo inet loopback
    # The primary network interface
    auto eth0
    iface eth0 inet dhcp

    /pxeroot/etc/hosts
    127.0.0.1 localhost debian
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

    /pxeroot/etc/fstab
    # <file system> <mount point> <type> <options> <dump> <pass>
    /dev/ram0 / ext2 defaults 0 0
    proc /proc proc defaults 0 1
    tmpfs /tmp tmpfs defaults 0 1

    /etc/dhcp3/dhcpd.conf
    subnet 192.168.1.0 netmask 255.255.255.0 {
    range 192.168.1.100 192.168.1.105;
    option subnet-mask 255.255.255.0;
    filename "pxelinux.0";
    next-server 192.168.1.9;
    option root-path "192.168.1.9:/pxeroot";
    option broadcast-address 192.168.1.255;
    }

    A pxe client can boot over the network, BUT the main issue is that NFS never mounts.
    I have the same error again and again :
    nfs, server not responding, time out, then still trying.

    Talking with olivier2b about this, he suggested to modify this file
    /pxeroot/etc/initramfs-tools/initramfs.conf
    with BOOT=nfs instead of BOOT=local = no change same error.
    I also tried with NFSROOT=auto and 192.168.1.9:/pxeroot, no change.

    Then he suggested to add host in hosts.allow files. Mine are like that :
    ALL:ALL (I tried with portmap:ALL and mountd:ALL, successless).

    Logs are :
    /var/log/messages
    Mar 21 16:55:59 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:55:59 debian dhcpd: DHCPREQUEST for 192.168.1.122 (192.168.1.10) from 00:0d:60:8e:72:84 via eth0: unknown lease 192.168.1.122.
    Mar 21 16:56:00 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:15 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:15 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:17 debian dhcpd: DHCPREQUEST for 192.168.1.105 (192.168.1.9) from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:17 debian dhcpd: DHCPACK on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:27 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:27 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:27 debian dhcpd: DHCPREQUEST for 192.168.1.105 (192.168.1.9) from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:27 debian dhcpd: DHCPACK on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0

    /var/log/syslog
    Mar 21 16:55:59 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:55:59 debian dhcpd: DHCPREQUEST for 192.168.1.122 (192.168.1.10) from 00:0d:60:8e:72:84 via eth0: unknown lease 192.168.1.122.
    Mar 21 16:56:00 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:15 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:15 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:17 debian dhcpd: DHCPREQUEST for 192.168.1.105 (192.168.1.9) from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:17 debian dhcpd: DHCPACK on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:17 debian in.tftpd[4037]: tftp: client does not accept options
    Mar 21 16:56:27 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:27 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:27 debian dhcpd: DHCPREQUEST for 192.168.1.105 (192.168.1.9) from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:27 debian dhcpd: DHCPACK on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:28 debian mountd[2074]: authenticated mount request from 192.168.1.105:835 for /pxeroot (/pxeroot)
    Mar 21 16:56:50 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:50 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:50 debian dhcpd: DHCPREQUEST for 192.168.1.105 (192.168.1.9) from 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:50 debian dhcpd: DHCPACK on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
    Mar 21 16:56:50 debian mountd[2074]: authenticated mount request from 192.168.1.105:877 for /pxeroot (/pxeroot)

    /var/log/daemon.log
    Mar 21 16:56:17 debian in.tftpd[4037]: tftp: client does not accept options
    Mar 21 16:56:28 debian mountd[2074]: authenticated mount request from 192.168.1.105:835 for /pxeroot (/pxeroot)
    Mar 21 16:56:50 debian mountd[2074]: authenticated mount request from 192.168.1.105:877 for /pxeroot (/pxeroot)

    I can't figure out what went wrong, but I did read a lot over Google regarding this kind of error.
    I tried several solutions :
    -change cable = no change same error;
    -change switch = no change same error;
    -I used several PC as clients, with different NIC = no change same error;
    -change tftp server by replacing tftpd-hpa by atftpd = no change same error;
    -did several changes over config files from my researches = no change same error;

    NFS is working, I can mount and access it with mount command...

    I did successfully set a platform to install OS by pxe boot, it works perfectly !

    What I want to do is booting over the network with PXE to load a custom debian install to perform hardware inventory (with OCS client), partitionning (with partimage) and hard drive wiping (with wipe).

    Many thanks for your time and your brain !

    Kind regards,
    S.
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's in /etc/exports?
     
  5. sebastienp

    sebastienp New Member

    As the Howto says,
    */etc/exports
    /pxeroot 192.168.1.0/255.255.255.0(rw,sync,no_root_squash,no_subtree_check)

    showmount -a
    /pxeroot 192.168.1.0/255.255.255.0

    Could it be a portmap problem ?
    rpcinfo -p localhost shows portmap, mountd and nfs active.

    Thx,
    S.
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Unfortunately I'm not sure where the problem is... :(
     
  7. sebastienp

    sebastienp New Member

    OK, many thanks again for the time you spent on this.
    I'll try another way.
     
  8. tapczan

    tapczan New Member

    Try to disable interafce eth0 by removing above lines. In my case this was the solution.
     

Share This Page