/boot not ready after syncing RAID 1 w/ virgin drive

Discussion in 'HOWTO-Related Questions' started by primal23, Jan 30, 2013.

  1. primal23

    primal23 New Member

    I am running Ubuntu 10.04, and used the How-to-setup RAID 1 on running system including GRUB2.

    So I was planning on doing the upgrade to 12.04, and wanted to have a backup in case something goes haywire. So I took out one hard drive, put in a blank, and booted Ubuntu, and synced the raid, and installed GRUB.

    Everything seemed fine, so I removed both drives and put in a blank as secondary, and the one I just synced into the primary, boot the system, and it takes me to the grub rescue menu.

    So shutting down the system and putting back the original primary back in, the system boots, but the Ubuntu gives me a message,

    /boot in not not ready or not installed

    I skip that, get into Ubuntu, and md0 is not active. When I tried to update-grub, or os-prober I get this error:

    ERROR: isw: wrong number of devices in RAID set "isw_dfichbebdi_Volume0:1" [1/2] on /dev/sda

    Grub seems to have an older linux kernel it's "stuck" on, and I can't find a way to change it to the one currently used by Ubuntu.

    Any help would be appreciated! Thanks!
  2. primal23

    primal23 New Member

    When I try to update grub I get this:

    root@******:~# update-grub
    Generating grub.cfg ...
    Found linux image: /boot/vmlinuz-2.6.32-36-generic-pae
    Found initrd image: /boot/initrd.img-2.6.32-36-generic-pae
    Found linux image: /boot/vmlinuz-2.6.32-36-generic
    Found initrd image: /boot/initrd.img-2.6.32-36-generic
    ERROR: isw: wrong number of devices in RAID set "isw_dfichbebdi_Volume0:1" [1/2] on /dev/sda

    And here is what Ubuntu runs for kernel:

    root@******:~# uname -r
  3. primal23

    primal23 New Member

    Got it solved, still get the error

    ERROR: isw: wrong number of devices in RAID set "isw_dfichbebdi_Volume0:1" [1/2] on /dev/sda

    But I can proceed with what I needed to get done, and work on that error when time allows, or if anyone has any ideas.

    Thanks again!

Share This Page