Bond issue Red Hat 5

Discussion in 'Server Operation' started by kopper, Sep 25, 2009.

  1. kopper

    kopper New Member

    guys

    we have 2 severs those servers have are using bonding

    the issue is servers suddenly stop responding I mean the services they provide are not accesible and the only way to get them back is taking the interface down and up for the switch so servers/services are available again

    We think is the driver NICs that might be very old...or the bond driver...

    This is a IBM Blade.

    Basically if you can provide me some guide on this.

    Information - I attached the messages_log
    Red Hat Enterprise release 5 (Tikanga)
    2.6.18-8.el5
    Ethernet Channel Bonding Driver: v3.0.3 (March 23, 2006) - BTW I would like to know how to update this driver to more recent version if that's possible?

    how can I get Driver version for NICs? command?

    I only get this
    Code:
    # dmesg | grep Eth
    NICs
    eth0: Tigon3 [partno(BCM95715s) rev 9003 PHY(5714)] (PCIX:133MHz:64-bit) 10/100/1000BaseT Ethernet
    
    eth2: Tigon3 [partno(BCM95714s) rev 9003 PHY(5714)] (PCIX:133MHz:64-bit) 10/100/1000BaseT Ethernet
    
    Ethernet Channel Bonding Driver: v3.0.3 (March 23, 2006)
    
    
    root@---bonding]# cat bond0
    Ethernet Channel Bonding Driver: v3.0.3 (March 23, 2006)
    
    Bonding Mode: load balancing (xor)
    Transmit Hash Policy: layer2 (0)
    MII Status: up
    MII Polling Interval (ms): 80
    Up Delay (ms): 0
    Down Delay (ms): 0
    
    Slave Interface: eth2
    MII Status: up
    Link Failure Count: 0
    Permanent HW addr: 00:1a:64:56:7f:66
    
    Slave Interface: eth3
    MII Status: up
    Link Failure Count: 0
    Permanent HW addr: 00:1a:64:56:7f:67
    
    
    [[email protected]]# ethtool eth2
    Settings for eth2:
    Supported ports: [ FIBRE ]
    Supported link modes: 1000baseT/Half 1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 1000baseT/Half 1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: FIBRE
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: g
    Wake-on: d
    Current message level: 0x000000ff (255)
    Link detected: yes
    
    [[email protected]]# ethtool eth3
    Settings for eth3:
    Supported ports: [ FIBRE ]
    Supported link modes: 1000baseT/Half 1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 1000baseT/Half 1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: FIBRE
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: g
    Wake-on: d
    Current message level: 0x000000ff (255)
    Link detected: yes
    thanks a lot
     

    Attached Files:

Share This Page