Bluetooth on laptop...working but...

Discussion in 'Technical' started by pebkac, Feb 20, 2009.

  1. pebkac

    pebkac Member

    (SOLVED) Bluetooth on laptop...working but...

    Hey all I have an Acer TravelMate C110, running Ubuntu 8.10, everything works great. My problem is the way I get the bluetooth on is by running this command each time the laptop boots up:

    Code:
    echo "1" > /proc/driver/acerhk/blueled
    My question is, how can I have that command run automatically as the system starts up?


    Thanks


    --Steve
     
    Last edited: Feb 27, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    You can add the command to /etc/rc.local. Might also be possible enable this in /etc/sysctl.conf, although I don't know the directive.
     
  3. pebkac

    pebkac Member

    thanks, I will try this as soon as I get home.
     
  4. pebkac

    pebkac Member

    i pasted the command into /etc/rc.local, and nothing happens.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Before the exit line?
     
  6. pebkac

    pebkac Member

    Yes......

    Code:
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    setserial /dev/ttyS0 port 0x06f8 irq 6 autoconfigure
    modprobe acerhk
    echo "1" > /proc/driver/acerhk/blueled
    
    exit 0
    I did read this and it says ubuntu does not really use the rc.local file anymore....Here 11.6 It looks as if Debian does not use rc.local to customize the boot process; what facilities are provided?

    So I tried it it mentions there and still no go....here is what is in that file...maybe I syntax or directive is wrong...not too sure...

    /etc/init.d/bluet
    Code:
    #!/bin/bash
    echo "1" > /proc/driver/acerhk/blueled
    when I try and run /etc/init.d/bluet start I get this:
    Code:
    [email protected]:~$ sudo /etc/init.d/bluet start
    [sudo] password for steve: 
    sudo: /etc/init.d/bluet: command not found
    [email protected]:~$ 
    
    any other ideas?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Please use full paths in /etc/rc.local (e.g. /sbin/modprobe instead of modprobe).
     
  8. pebkac

    pebkac Member

    well tried adding /sbin/modprobe instead but still dont work? thanks....
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Did you make /etc/init.d/bluet executable?
     
  10. pebkac

    pebkac Member

    I did not think I did, so I did it and still nothing. I went ahead a made a new file and did the following and still no go....

    Code:
    [email protected]:~$ sudo chmod -x /etc/init.d/bluetoo
    [email protected]:~$ ls /etc/init.d/bluetoo
    /etc/init.d/bluetoo
    [email protected]:~$ ls -l /etc/init.d/bluetoo
    -rw-r--r-- 1 root root 51 2009-02-26 12:25 /etc/init.d/bluetoo
    [email protected]:~$ sudo update-rc.d bluetoo defaults 19
    update-rc.d: warning: /etc/init.d/bluetoo missing LSB style header
     Adding system startup for /etc/init.d/bluetoo ...
       /etc/rc0.d/K19bluetoo -> ../init.d/bluetoo
       /etc/rc1.d/K19bluetoo -> ../init.d/bluetoo
       /etc/rc6.d/K19bluetoo -> ../init.d/bluetoo
       /etc/rc2.d/S19bluetoo -> ../init.d/bluetoo
       /etc/rc3.d/S19bluetoo -> ../init.d/bluetoo
       /etc/rc4.d/S19bluetoo -> ../init.d/bluetoo
       /etc/rc5.d/S19bluetoo -> ../init.d/bluetoo
    [email protected]:~$ /etc/init.d/bluetoo start
    bash: /etc/init.d/bluetoo: Permission denied
    [email protected]:~$ sudo /etc/init.d/bluetoo start
    sudo: /etc/init.d/bluetoo: command not found
    [email protected]:~$ 
    
     
  11. pebkac

    pebkac Member

    Solved

    falko, thanks for all the help, you got me digging in all the right places. It is now working. For some reason when I ran:
    Code:
    sudo chmod -x /etc/init.d/bluetoo
    it did not make it executable as an application. I had to run nautalis as root and check the box that says run as application or something to that effect, did a reboot and the bluetooth started up perfectly.

    Thanks again.

    --Steve
     

Share This Page