bluetooth and pin_helper

Discussion in 'Desktop Operation' started by rickygm, Jan 24, 2008.

  1. rickygm

    rickygm New Member

    hello forum, I am trying to connect my cellular phone sony ericsson w880i with my centos 5, I have installed the packages

    bluez-utils-3.7-2.el5.centos
    bluez-libs-3.7-1
    bluez-hcidump-1.32-1

    when I restart the bluetooth he tells me that it doesn't recognize the password

    Unknown option 'pin_helper' line 5
    Jan 23 22:11:23 xserver hcid[22723]: syntax error line 5
    Jan 23 22:11:23 xserver hcid[22723]: Register path:/org/bluez fallback:1

    I have trying with passkey and pin_helper but it doesn't work me

    :(
     
  2. topdog

    topdog New Member HowtoForge Supporter

    Post your configuration, as you can see from the logs you have a syntax error on line 5 of one of your configuration files am guessing /etc/bluetooth/hcid.conf
     
  3. rickygm

    rickygm New Member

    options {
    autoinit yes;
    security auto;
    pairing multi;
    pin_helper /usr/bin/bluepin;
    }

    device {
    name "MY PHONEC";
    class 0x000100;
    iscan enable; pscan enable;
    lm accept;
    lp rswitch,hold,sniff,park;
    }
     
  4. topdog

    topdog New Member HowtoForge Supporter

    the "pin_helper" option is only valid with bluez-libs-2.x & bluez-utils-2.x and below.

    Thats what is causing the service to fail to start up.

    Bluez-3.X has replaced pin helpers with passkey agents such as kbluetoothd and bluez-gnome, the bluez-utils also comes with an command line agent passkey-agent.
     
    Last edited: Jan 24, 2008
  5. rickygm

    rickygm New Member

    but that command passkey-agent doesn't have it installed, and my version of is

    bluez-gnome-0.5-5.fc6

    ?

    with the option of the passkey inside the hcid.conf, the cellular one requests me the PASSWORD every 5 seconds and it doesn't connect with my PC

    as I can solve that?
     
  6. topdog

    topdog New Member HowtoForge Supporter

    First you need to remove that option from your hcid.conf file then restart bluetooth, if you leave the option in bluetooth will not run.

    I have not used bluez-gnome as i use kbluetoothd, but it is supposed to popup a dialog for you to type the pin in.
     

Share This Page