Bizare postfix problems with file ownership

Discussion in 'Server Operation' started by lazacom, Sep 3, 2012.

  1. lazacom

    lazacom New Member

    I had problem with non working postfix server (after unsucessfuly completed ISPConfig installation) and I solved it with removing it (yum remove postfix) and installing it from source (postfix 2.9.4, built as root).

    I had to install 2.7 or newer because virtualmin forced me. After that, mail server started to send test email and could get it.

    But, after that, I noticed that I can receive outside emails but can not send mails to any other domain (only to other emails on my domain, nemogucamisija.com). Error code was:
    Then I noticed that postfix can not access certificate. Disabled TLS but now I can not set Transport Mapping, cause postfix can not access /etc/postfix/transport . Tried
    and
    I know building it as a root was not smartest idea, but tutorial required it. So, what I shoul do to fix this? Or, any other solution to enable sending emails to other domains than my own?

    Thanks in advance!
     
  2. TiTex

    TiTex New Member

    what about /etc/postfix/ dir permisions ?

    ls -ld /etc/postfix/
     
  3. lazacom

    lazacom New Member

    drwxr-xr-x 2 root root 4096 Sep 3 11:22 /etc/postfix/
     
  4. TiTex

    TiTex New Member

    Last edited: Sep 3, 2012
  5. lazacom

    lazacom New Member

    Ok, will do it, but my main problem is no more TLS support, but to enable postfix to send emails outside my domain. Do you have some solution for that? It seems that without transport mapping I can't do that.

    And I can't make postfix access those files (/etc/postfix/transport), it keeps telling me:
     
  6. TiTex

    TiTex New Member

    that is very abstract , you should better check /var/log/maillog for more informations upon what's wrong.
    also if you followed a HowTo , you should post the link but first dublechek it ... maybe you've missed something in your configuration.
     
  7. lazacom

    lazacom New Member

    After server reboot, postfix is finally able to access files, including /var/log/maillog. But I still can not send mails to external domains. Here is output of maillog:
    where first line looks suspicious to me. Any help?
     
  8. lazacom

    lazacom New Member

    Closed and opened new thread for new problem. Tnx
     

Share This Page