Bind9 doesn't start after (re)boot.

Discussion in 'Installation/Configuration' started by Guido64, Feb 18, 2016.

  1. Guido64

    Guido64 Member

    I installed a new clean "Perfect server" based on Debian Jessie in a openvz vps on my own local home server. Wen i start the vps or do a restart bind is not starting i have to manualy start it everytime. In ISPConfig > Services DNS is checked. And under rescue there is no dns option to select. Should there be a dns option under rescue (watchdog)?
  2. Active Member

    If bind is installed as a system service it should start automatically. Are there any hints in your syslog at boot time indicating a fail when trying to start bind?
  3. Guido64

    Guido64 Member

    There is nothing in syslog from named an/or bind9 in the syslog.
    I installed everything like it is written in the perfect server tutorial there is nothing in the tutorial abount setting bind as system service mode AFAIN. It only says: apt-get install bind9 dnsutils

    If i start it manualy it works just after every boot i have to start bind myself.
    There is nothing in syslog from named / bind / bind9.

    [email protected]:~# insserv -s | grep bind
    K:04:0 1 2 3 4 5 6:bind9
    K:08:0 1 6 S:rpcbind
  4. Active Member

    hmmm rather unusual - are there any dns zones configured yet? quick google search tought me ither ppl had that issue, too in various systems and remove / install bind9 resolved the issue.
    Guido64 likes this.
  5. Guido64

    Guido64 Member

    Yes i had one test domain setup that i removed and also removed bind9, rebooted, re-installed and rebooted again and ...
    [email protected]:~# ps aux | grep named
    bind 248 0.0 0.0 338908 20 ? Ssl 20:18 0:00 /usr/sbin/named -f -u bind

    Thank you again !!!

Share This Page