BIND unable to start after installation

Discussion in 'Installation/Configuration' started by blaszlo, Aug 27, 2008.

  1. blaszlo

    blaszlo New Member

    Hey guys,

    I just installed ISPConfig and setup my server with howtoforge perfect server setup for my CentOS 4.4 machine and everything seems to be working OK all except for BIND, which is extremely important. Below is the error I got...


    [[email protected] ~]# /etc/init.d/named start
    Starting named:
    Error in named configuration:
    /etc/named.conf:3: change directory to '/var/named/chroot/var/named' failed: file not found
    /etc/named.conf:3: parsing failed
    [FAILED]
    [[email protected] ~]#


    I did install a bind-chroot, but somehow I think the configuration changed or something happened during the install of ISPConfig... Any help is greatly appreciated. Thanks!!!
     
  2. matrixn

    matrixn New Member

    open /etc/named.conf and check the path at the line 3... should be something like "/var/lib/named" then follow the path and see if the named has proper files here.

    I saw that your path at line 3 is "/var/named/chroot/var/named".. strange...
    which distro u use?
     
  3. blaszlo

    blaszlo New Member

    Thanks, we'll see what that leads me to. I stated in my original post that I was using CentOS 4.4
     
  4. matrixn

    matrixn New Member

    my mistake about distro ... i haven`t realize that is writed... :)) and.. by the way for me it looks so strange this path "/var/named/chroot/var/named"

    :confused:
     
  5. blaszlo

    blaszlo New Member

    That is the path for chrooted bind server, used as a trick for unauthorized people, almost like a symbolic link that is inaccessible... When someone tries to go to the default installation path, its not there (not sure exactly how it works). Any more help from anybody would be great!
     
  6. blaszlo

    blaszlo New Member

    My /var/named directory has symbolic links like they are supposed to... my /var/named/chroot/var/named directory has all of the zone files that it is supposed to have, so I find it very strange that the error tells me 'file not found'... What file is it looking for exactly?
     
  7. matrixn

    matrixn New Member

    well .. in the named.conf line 3 it`s a path to a directory not a path to a file.
    at line 2 is a path for a file called named.pid wich is the id numer of the named proccess i think...

    post your named.conf here.. to see if it`s a problem...

    what i have in named...first 4 lines

    options{
    pid-file "/var/lib/named/var/run/named/named.pid";
    directory "/var/lib/named";
    auth-nxdomain no;
    /*some comments */
    };

    check the syntax on your named.conf...

    my structure of dir/files in /var/lib/named:

    dev
    dyn
    etc
    log
    master
    slave
    var

    some.zone ///my zone files
    root.hint

    i hope that helps in a way or another...

    LE: it should be an owner/permisions problem...

    Excuse my bad english.. i`m from Romania..
     
  8. blaszlo

    blaszlo New Member

    Here is my named.conf...

    options {
    pid-file "/var/named/chroot/var/run/named/named.pid";
    directory "/var/named/chroot/var/named";
    auth-nxdomain no;
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };

    //
    // a caching only nameserver config
    //
    zone "." {
    type hint;

    As you can see, my named.conf file is in a different location than yours... Is yours chrooted? Also, the named.pid file DOES NOT EXIST... Exactly what is supposed to be in this file?
     
    Last edited: Aug 28, 2008
  9. blaszlo

    blaszlo New Member

    OKAY!!!! Fixed the problem by changing the permissions, but I still have an issue...

    http://www.intodns.com/bradlaszlo.com

    The above link shows that I DO NOT HAVE NAMESERVER RECORDS!! What the hell do I do?!?!?! I am fairly new to the linux world, and I have never had these sort of problems on Windows Server
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Please create the dns records in the ISPConfig DNS-Manager for the domain bradlaszlo.com.
     
  11. blaszlo

    blaszlo New Member

    GREAT! I rebooted my server and now DNS will not start again... It appears that the named.conf file has been changed automatically by ISPConfig and again doesnt have the permissions it needs, I don't know what else to do...
     
    Last edited: Aug 28, 2008
  12. blaszlo

    blaszlo New Member

    Nevermind guys... Thanks for the help though! I just installed CentOS 4.6 then re-installed ISPConfig, I think the problem was during the original configuration of the server and ISPConfig... I think the hostname I set was invalid so I made sure it was right this installation and all is well now with dns. Thanks again!
     

Share This Page