Bind-Server doesn't start Centos 5.3

Discussion in 'General' started by oepastor, Apr 3, 2009.

  1. oepastor

    oepastor New Member

    I've installed ISPConfig 2.2.31 in a Centos 5.3 server.
    The installation works fine and start the panel ok.
    But when I configure the server and configure one test site the BIND-Server doesn't work any more.
    In the panel only says OFFLINE.
    In the server console I have this:

    [root@ns2 ~]# service named start
    Starting named:
    Error in named configuration:
    /etc/named.conf:3: change directory to '/home/admispconfig/ispconfig/web/multidoc/edit' failed: file not found

    /etc/named.conf:3: parsing failed
    [FAILED]

    As I don't know which is the pointing file or the misconfiguration I request your help.

    Thank you.
     
  2. till

    till Super Moderator

  3. oepastor

    oepastor New Member

    Till

    I've have done all the installation as is described in the post but bind doesn't work.
    I'm using bind-9.3.4 but I suppose that is the same 9.3.3

    Please tell me if there may be another thing to do.

    Thanks
     
  4. till

    till Super Moderator

    Did you set the correct path to the bind directory in ispconfig under management > server > settings and clicked on save?
     
  5. oepastor

    oepastor New Member

    I didn't touch the default value.
    Please tell me what must say o which is the correct path.
    Thanks
     
  6. oepastor

    oepastor New Member

    If I uninstall the panel and make a new installation this problem can be solved or I will have another problem or a bigger one???
    Or for a new installation I must have a clean system installation.
     
  7. falko

    falko Super Moderator

    What's the path to the bind directory in ispconfig under management > server > settings right now?

    Did you change the permissions as shown in the "Perfect Server" setup for CentOS 5.2?

    Code:
    chmod 755 /var/named/
    chmod 775 /var/named/chroot/
    chmod 775 /var/named/chroot/var/
    chmod 775 /var/named/chroot/var/named/
    chmod 775 /var/named/chroot/var/run/
    chmod 777 /var/named/chroot/var/run/named/
    cd /var/named/chroot/var/named/
    ln -s ../../ chroot
    cp /usr/share/doc/bind-9.3.4/sample/var/named/named.local /var/named/chroot/var/named/named.local
    cp /usr/share/doc/bind-9.3.4/sample/var/named/named.root /var/named/chroot/var/named/named.root
    touch /var/named/chroot/etc/named.conf
    chkconfig --levels 235 named on
    /etc/init.d/named start
     
  8. oepastor

    oepastor New Member

    This is my configuration.

    BIND User: named
    BIND Group: named

    named.conf: /var/named/chroot/etc/named.conf

    Zonefiles Dir.: /home/admispconfig/ispconfig/web/multidoc/edit

    Default Ns1: ns1.dobryhost.net
    Default Ns2: ns2.dobryhost.net
    Admin Email:
    Default MX: x

    I've set he permissions as is described.
     
  9. falko

    falko Super Moderator

    Please change it to /var/named/chroot/var/named.
     
  10. oepastor

    oepastor New Member

    Thanks

    Thanks Falco, at last it works.
    But I've must change myself the line in named.conf because the panel doesn't.
    Anyway, it is working now, thank you.
    Oscar
     

Share This Page