BIND Problem

Discussion in 'Installation/Configuration' started by asterinux, Apr 11, 2013.

  1. asterinux

    asterinux New Member

    Hi Guys,

    Im stuck in configuring my DNS to work with ISPConfig I can say that my dns is working because i can dig / nslookup the records that i added to the zone. But the zone that was created by ISPConfig GUI, I cant dig or nslookup into it. In my /etc/named.conf file i included the named.conf.local which is used by ISPConfig.


    include "/etc/named/rfc1912.zones";
    #####include "/var/named/chroot/etc/named.conf.local";
    include "/etc/named.conf.local";

    zone "" {
    type master;
    allow-transfer {none;};
    file "/var/named/data/";
    ...i cant dig/nslookup the records in zone. By the way im using BIND 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6.3 chrooted. Would like to know if i am missing something in the setup.

  2. asterinux

    asterinux New Member

    its solved!

    just to update this thread,, its solved.

    what i did is, i create an empty file /var/named/chroot/etc/named.conf.local and link it to /etc/named.conf.local

    ll /etc/named.conf.local
    lrwxrwxrwx 1 root root 38 Apr 12 17
    :16 /etc/named.conf.local -> /var/named/chroot/etc/named.conf.local
    ... and after reloading, creating new zone under the ISPConfig GUI, i can now dig and ping the record ive created.

    Let me know if this is the right thing to do. ;)
  3. Transmaniacon MC

    Transmaniacon MC New Member

    I too am interested.


Share This Page