1. I have literally followed the follwoing Howto http://www.howtoforge.com/perfect-server-ubuntu8.04-lts-p4
    and installed ISPconfig successfuly but bind not working any clue
    Thanks in advance for your help
    here's the error msg
    [email protected]:/# /etc/init.d/bind9 restart
    * Stopping domain name service... bind
    rndc: connect failed: connection refused
    * Starting domain name service... bind [fail]
  2. toxical

    toxical New Member

    Problem with BIND

    Hi all,

    I have following problem.

    I have installed ISPConfig on ubuntu 8.04lts. I have problem with bind. For example i have domain a.ttt.tt, I checked a.ttt.tt has ns record for my bind server. When I'm running nslookup for a.ttt.tt it always returns correct dns address. After all I'm creating new web site, in place for domain I'm adding a.ttt.tt and for host name I'm writing www.

    After this I'm trying to open www.a.ttt.tt but unfortunately no response for it.
    I checked there is record for www.a.ttt.tt on /etc/bind/pre.a.ttt.tt but for www.a.ttt.tt, but after nslookup www.a.ttt.tt mydnshost I get Refused answer.

    Thanks in advance.
    Last edited: Sep 22, 2008
  3. falko

    falko Super Moderator ISPConfig Developer

    Please check with
    dig ns yourdomain.com 
    that you're creating the DNS records o nthe correct name servers.
  4. toxical

    toxical New Member

    Thanks for your answer. I checked, when I'm running command form my server machine it always returns correct result, but when I'm running it from another host it returns

    ; <<>> DiG 9.3.4 <<>> ns www.tt.ttt.tt
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 61890
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;www.tt.ttt.tt. IN NS

    ;; Query time: 0 msec
    ;; SERVER: 777.77.778.773#53(777.77.778.773)
    ;; WHEN: Thu Sep 25 05:31:18 2008
    ;; MSG SIZE rcvd: 32

    Sorry for hiding real addresses:)
  5. chipsafts

    chipsafts New Member

    are you sure you have the finishing dot in your config file?

    restart the named and check the messages log for all the named entries.

Share This Page