BIND Problem

Discussion in 'Installation/Configuration' started by vladimirp, Oct 23, 2007.

  1. vladimirp

    vladimirp New Member

    I''ve installated Ispconfig according to perfect setup centos 5 :
    9 Install A Chrooted DNS Server (BIND9)
    To install a chrooted BIND9, we do this:

    yum install bind-chroot

    Then do this:

    chmod 755 /var/named/
    chmod 775 /var/named/chroot/
    chmod 775 /var/named/chroot/var/
    chmod 775 /var/named/chroot/var/named/
    chmod 775 /var/named/chroot/var/run/
    chmod 777 /var/named/chroot/var/run/named/
    cd /var/named/chroot/var/named/
    ln -s ../../ chroot
    cp /usr/share/doc/bind-9.3.3/sample/var/named/named.local /var/named/chroot/var/named/named.local
    cp /usr/share/doc/bind-9.3.3/sample/var/named/named.root /var/named/chroot/var/named/named.root
    touch /var/named/chroot/etc/named.conf
    chkconfig --levels 235 named on
    /etc/init.d/named start
    But in ispconfig I see :
    named.conf : /var/named/chroot/etc/named.conf
    Zonefiles Dir.: /etc/bind
    why ????? :confused: :confused:
    and I cant change /etc/bind -> /var/named/chroot/var/named/ : ???

    [root@www ~]# cd /etc/bind
    -bash: cd: /etc/bind: No such file or directory
    [root@www ~]# cd /var/named/chroot/var/named/
    [root@www named]# ll
    total 48
    lrwxrwxrwx 1 root named 6 Jul 14 03:26 chroot -> ../../
    drwxrwx--- 2 named named 4096 Aug 25 2004 data
    -rw-r----- 1 root named 426 Jul 14 03:26 named.local
    -rw-r----- 1 root named 2518 Jul 14 03:26 named.root
    -rw-r--r-- 1 named named 648 Oct 20 15:32 pri.170.254.85.in-addr.arpa
    -rw-r--r-- 1 named named 584 Oct 20 15:32 pri.170.254.85.in-addr.arpa~
    -rw-r--r-- 1 named named 778 Oct 20 15:32 pri.advance.lv
    -rw-r--r-- 1 named named 777 Oct 20 15:32 pri.advance.lv~
    -rw-r--r-- 1 named named 775 Oct 20 15:31 pri.myhost.lv
    -rw-r--r-- 1 named named 774 Oct 20 15:31 pri.myhost.lv~
    drwxrwx--- 2 named named 4096 Jul 27 2004 slaves

    May be everything is correct , but BIND serviss now is offline , I don't now why ...
    [root@www named]# /etc/init.d/named start
    Starting named:
    Error in named configuration:
    /etc/named.conf:3: change directory to '/home/admispconfig/ispconfig/web/multidoc/edit' failed: file not found

    /etc/named.conf:3: parsing failed
    [FAILED] .
    1. Should I see /etc/bind , is it correct ???? :confused:
    2. Why I can start named ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that the path to your named.conf file is set correctly in ISPConfig under management > server > settings.
     
  3. vladimirp

    vladimirp New Member

    [root@www ~]# find / -name "named.conf"
    /var/named/chroot/etc/named.conf
    /etc/dbus-1/system.d/named.conf
    /usr/share/doc/bind-9.3.3/sample/etc/named.conf
    /usr/share/logwatch/default.conf/services/named.conf


    In ISPconfig management->server->settings->isp server -> dns

    named.conf: /var/named/chroot/etc/named.conf

    Iwill trying to reinstall bind...
     
  4. falko

    falko Super Moderator ISPConfig Developer

    And what's the value of the zonefiles directory?
     
  5. tal56

    tal56 New Member

    I'm having the same problem, if my setting are this :

    named.conf: /var/named/chroot/etc/named.conf
    Zonefiles Dir.: /home/admispconfig/ispconfig/web/multidoc/edit

    Is that not correct? They seem to be pointing at different directories.

    I'm on Centos 5.4, which directory should those 2 files be pointing at?

    Thanks !

     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page