bind problem

Discussion in 'General' started by flourishing, Dec 10, 2005.

  1. flourishing

    flourishing ISPConfig Developer

    i installed bind-chroot ,but the file /etc/named.conf always is

    options {
    pid-file "/var/run/named/named.pid";
    directory "/var/named";

    auth-nxdomain no;
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };
    the red part. even i change that to /var/named/chroot ....
    and copied /var/named/name.* pr* /var/named/chroot/var/named/
    when restart the named.conf change to orignal. set the directory to /var/named
    and the ispconfig dns manager auto create the pri-file in the directory /var/named

    what should i do?
    i am just wondering . the same install sequence ,why this time the bind-chroot can't work fine.
     
  2. till

    till Super Moderator

    Change the config template of the named.conf in /root/ispconfig/isp/conf
     
  3. falko

    falko Super Moderator

    You can set the named directory in ISPConfig: Management -> Server -> Settings -> DNS.
     

Share This Page