Bind not starting

Discussion in 'Installation/Configuration' started by tal56, Feb 6, 2009.

  1. tal56

    tal56 Member

    Hi guys,

    I've been running a pretty stable ispconfig 2 so far and recently just noticed my Bind is down and I can't get it to start. This might have happened after my recent yum update and installation of ispconfig 2.2.29.

    This is what I get when I try to restart the bind server :
    I've been through a few threads and found that I needed to change my zonefiles dir to "/var/named/chroot/var/named" and I've done that, and it does stay when I go back and check it again under the management-settings-dns tab.

    I do wait a few minutes to retry this but still get the same problem. I'm now stuck and don't know where to look anymore. Can someone please point me to some suggestions. Thank you
  2. tal56

    tal56 Member

    Ok I may have resolved this on my own, but please let me know if what I did was the right thing to do. I don't want to mess anything else up.

    I checked the content of my "/var/named/chroot/etc/named.comf" file and noticed the third line looked like this :

    directory "/home/admispconfig/ispconfig/web/multidoc/edit";

    so I changed it to this :

    directory "/var/named/chroot/var/named";

    and now everything seems to be working ok. I hope that was the right thing I needed to do.

    Also I have not went to changed any configuration or anything, so I assumed this must have happened because of the yum update, or ispconfig update. I'm using Centos 5.2 but started from 5.0, so has anyone else ran into this? If so maybe this should be fixed for future versions. Thanks
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not the solution for the problem as it will occur again. the real problem is that the permissions of the bind directory are wrong. Set the permissions again as described in the perfect setup guide and then set the correct bind directory in ispconfig.

    This is a bug in yum. Yum destrooys permissions of bind folders when it updates bind instead of preventing them.
  4. tal56

    tal56 Member

    Hi Till,

    I did do the permission changes from the perfect install but it didn't seem to fix the problem until I changed that file. Below is the steps I've done

    Except I did not do the two "cp" commands as I didn't want to overwrite my current configs.

    In my management-settings-dns tabs here are my two fields :
    named.conf: /var/named/chroot/etc/named.conf
    Zonefiles Dir.: /var/named/chroot/var/named

    I've kept a backup of the original named.conf before I changed the directory, so I can easily put it back. But I'd like to get this fixed right. What should I be doing?

    Thanks Till
  5. falko

    falko Super Moderator ISPConfig Developer

    You could've modified some records or add a record in ISPConfig - ISPConfig would then have rewritten named.conf with the correct directory. But doing this manually is ok as well.
  6. tal56

    tal56 Member

    Thanks Falko

    I guess from what you are saying it's ok for me to leave things as they are now. Thanks
  7. tal56

    tal56 Member

    Hi guys, Looks like I'm having this problem again. I've just updated Centos and installed the newest ISPconfig 2, however each time I update a website Bind dies and I get this error when trying to restart it.

    The named.conf file in the DNS setting tab, on ISPconfig is set at :

    I've ran through the DNS setup stuff from the Perfect Install for Centos 5.3 even though I'm running 5.4 now, because I don't think there's a Perfect Install for 5.4 (on a i386) system. The steps I ran through again were :

    Can someone tell me which named.conf file ispconfig 2 should be using ??
    This one : /home/admispconfig/ispconfig/web/multidoc/edit
    Or this ? : /var/named/chroot/var/named
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The solution is the same. Just do what is written in this thread.

    You posted the answer in #4
  9. tal56

    tal56 Member

    Sorry for the double post, they both had slightly different fixes, so I wasn't sure which was the right one.

    I've changed both my named.conf and zonefiles to /var/named/chroot/.... now, and things seem to be fine for now.

    Not sure why my zonefiles dir got changed to "/home/admispconfig/ispconfig/web/multidoc/edit", but maybe it was because of an update or something.

  10. happz

    happz Member

    New install of fedora 12 32bit with DNS problem

    Fresh install that never brought up DNS.
    I ran /etc/init.d/named restart to see what I would get and this is the result::::

    Starting named:
    Error in named configuration:
    zone localhost.localdomain/IN: loading from master file named.localhost failed: file not found
    _default/localhost.localdomain/IN: file not found
    zone localhost/IN: loading from master file named.localhost failed: file not found
    _default/localhost/IN: file not found
    zone loading from master file named.loopback failed: file not found
    _default/ file not found
    zone loading from master file named.loopback failed: file not found
    _default/ file not found
    zone loading from master file named.empty failed: file not found
    _default/ file not found

    ADDED NOTE: I found that I don't even have a named.conf could that happen
    and how can i fix it? I did the fedora 12 64Bit on a fedora 12 32 bit install with Perfect SRV
    instruction. Done this many times so not sure what could have happened...

    ISPConfig 2 by the way..


Share This Page