Bind not resolving ?

Discussion in 'Server Operation' started by bryxal, Mar 4, 2008.

  1. bryxal

    bryxal New Member

    Greetings I cannot resolve any hostnames from my box after running the Ubuntu 7.10 perfect set up. It cannot ping google.ca but it can ping itself via its hostname bryxal.ca.

    Thank you very much for any information regarding this.

    Here are what i would believe are the useful information:


    netstat -tap:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:mysql *:* LISTEN 4575/mysqld
    tcp 0 0 *:www *:* LISTEN 5052/apache2
    tcp 0 0 *:81 *:* LISTEN 4973/ispconfig_http
    tcp 0 0 64.26.154.106:domain *:* LISTEN 26577/named
    tcp 0 0 localhost:domain *:* LISTEN 26577/named
    tcp 0 0 localhost:953 *:* LISTEN 26577/named
    tcp 0 0 *:smtp *:* LISTEN 26503/master
    tcp 0 0 *:https *:* LISTEN 5052/apache2
    tcp6 0 0 *:imaps *:* LISTEN 4683/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 4723/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 4701/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 4663/couriertcpd
    tcp6 0 0 *:ssh *:* LISTEN 27167/sshd
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 26577/named
    tcp6 0 0 *:smtp *:* LISTEN 26503/master
    getnameinfo failed
    getnameinfo failed
    tcp6 0 0 [UNKNOWN]:ssh [UNKNOWN]:4757 ESTABLISHED26655/0
    getnameinfo failed
    getnameinfo failed
    tcp6 0 1000 [UNKNOWN]:ssh [UNKNOWN]:1082 ESTABLISHED27208/1



    vi /etc/network/interfaces

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 64.26.154.106
    netmask 255.255.255.248
    network 64.26.154.104
    broadcast 64.26.154.111
    gateway 64.26.154.105
    dns-nameservers 216.254.136.209 216.254.141.2




    named.conf:
    options {
    pid-file "/var/run/bind/run/named.pid";
    directory "/etc/bind";
    auth-nxdomain no;
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };

    //
    // a caching only nameserver config
    //
    zone "." {
    type hint;
    file "db.root";
    };

    zone "0.0.127.in-addr.arpa" {
    type master;
    file "db.local";
    };

    zone "154.26.64.in-addr.arpa" {
    type master;
    file "pri.154.26.64.in-addr.arpa";
    };


    zone "bryxal.ca" {
    type master;
    file "pri.bryxal.ca";
    };



    //// MAKE MANUAL ENTRIES BELOW THIS LINE! ////



    db.root:

    ; <<>> DiG 9.2.3 <<>> ns . @a.root-servers.net.
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18944
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 13, AUTHORITY: 0, ADDITIONAL: 13

    ;; QUESTION SECTION:
    ;. IN NS

    ;; ANSWER SECTION:
    . 518400 IN NS A.ROOT-SERVERS.NET.
    . 518400 IN NS B.ROOT-SERVERS.NET.
    . 518400 IN NS C.ROOT-SERVERS.NET.
    . 518400 IN NS D.ROOT-SERVERS.NET.
    . 518400 IN NS E.ROOT-SERVERS.NET.
    . 518400 IN NS F.ROOT-SERVERS.NET.
    . 518400 IN NS G.ROOT-SERVERS.NET.
    . 518400 IN NS H.ROOT-SERVERS.NET.
    . 518400 IN NS I.ROOT-SERVERS.NET.
    . 518400 IN NS J.ROOT-SERVERS.NET.
    . 518400 IN NS K.ROOT-SERVERS.NET.
    . 518400 IN NS L.ROOT-SERVERS.NET.
    . 518400 IN NS M.ROOT-SERVERS.NET.

    ;; ADDITIONAL SECTION:
    A.ROOT-SERVERS.NET. 3600000 IN A 198.41.0.4
    B.ROOT-SERVERS.NET. 3600000 IN A 192.228.79.201
    C.ROOT-SERVERS.NET. 3600000 IN A 192.33.4.12
    D.ROOT-SERVERS.NET. 3600000 IN A 128.8.10.90
    E.ROOT-SERVERS.NET. 3600000 IN A 192.203.230.10
    F.ROOT-SERVERS.NET. 3600000 IN A 192.5.5.241
    G.ROOT-SERVERS.NET. 3600000 IN A 192.112.36.4
    H.ROOT-SERVERS.NET. 3600000 IN A 128.63.2.53
    I.ROOT-SERVERS.NET. 3600000 IN A 192.36.148.17
    J.ROOT-SERVERS.NET. 3600000 IN A 192.58.128.30
    K.ROOT-SERVERS.NET. 3600000 IN A 193.0.14.129
    L.ROOT-SERVERS.NET. 3600000 IN A 199.7.83.42
    M.ROOT-SERVERS.NET. 3600000 IN A 202.12.27.33

    ;; Query time: 81 msec
    ;; SERVER: 198.41.0.4#53(a.root-servers.net.)
    ;; WHEN: Sun Feb 1 11:27:14 2004
    ;; MSG SIZE rcvd: 436
     
  2. topdog

    topdog New Member HowtoForge Supporter

    What is in /etc/resolv.conf ?
     
  3. bryxal

    bryxal New Member

    and voila!

    I didn't have the correct nameservers there... I didn't know of that file. thank you very much!!
     

Share This Page