BIND/named stoped working

Discussion in 'Installation/Configuration' started by Richard87, Jun 22, 2007.

  1. Richard87

    Richard87 New Member

    Hello, I thought I got BIND to work, but it had stoped working again,

    here is what happens when I start it with /etc/init.d/named start
    [[email protected] ~]# /etc/init.d/named start
    Starting named:
    Error in named configuration:
    /etc/named.conf:3: change directory to '/home/admispconfig/ispconfig/web/multidoc/edit' failed: file not found

    /etc/named.conf:3: parsing failed

    Any idea?

    (btw, I am running Fedora 7 with the Perfect server guide)
  2. adriaan

    adriaan New Member

    Same problem here: fedora 6 I think. Where can I find that?
    (Using ISPConfig 2.3.2)
  3. mlz

    mlz New Member

    If your running a chrooted bind, that line will not work unless the file is in the jail with the bind data files. It's weird too because I don't have that line in my named.conf Are you also running 2.3.2 Richard?
  4. falko

    falko Super Moderator ISPConfig Developer

  5. Richard87

    Richard87 New Member

    I am running this one: ISPConfig-2.2.14.tar.gz

    btw, about the files not in the chroot does make sense, will it be secure if I add a symbolic link to the external conf files, or will it just make things worse?

    added a symbolic link to the edit folder, and editted the named.conf file correctly, but it still wouldnt work...

    any idea?
    Last edited: Jun 24, 2007
  6. Richard87

    Richard87 New Member

    Thanks, that I read that link a little more carefully, and solved the directory problem, but a new problem arised:

    [[email protected] etc]# /etc/init.d/named start
    Starting named:
    Error in named configuration:
    zone loaded serial 42
    zone loading from master file failed: file not found
    _default/ file not found
    zone NS '' has no address records (A or AAAA)
    zone loaded serial 2007062101
    Any Idea?
  7. falko

    falko Super Moderator ISPConfig Developer

    What's in your named.conf? Does exist?
  8. Richard87

    Richard87 New Member

    this is the content of named.conf:
    [[email protected] ~]# cat /var/named/chroot/etc/named.conf
    options {
            pid-file "/var/named/chroot/var/run/named/";
            directory "/var/named/chroot/var/named";
            auth-nxdomain no;
             * If there is a firewall between you and nameservers you want
             * to talk to, you might need to uncomment the query-source
             * directive below.  Previous versions of BIND always asked
             * questions using port 53, but BIND 8.1 uses an unprivileged
             * port by default.
            // query-source address * port 53;
    // a caching only nameserver config
    zone "." {
            type hint;
            file "";
    zone "" {
            type master;
            file "named.local";
    zone "" {
            type master;
            file "";
    zone "" {
            type master;
            file "";
    ( does not exist)
  9. falko

    falko Super Moderator ISPConfig Developer

    And what are the outputs of
    ls -la /var/named/chroot/var/named
  10. Richard87

    Richard87 New Member

    here is the results of ls -la /var/named/chroot/var/named:
    [[email protected] ~]# ls -la /var/named/chroot/var/named/
    total 64
    drwxr-x--- 6 root  named 4096 2007-06-21 01:54 .
    drwxr-x--- 5 root  named 4096 2007-06-21 01:28 ..
    lrwxrwxrwx 1 root  named    6 2007-06-20 17:40 chroot -> ../../
    drwxrwx--- 2 named named 4096 2004-08-25 22:51 data
    drwxrwx--- 2 root  named 4096 2007-06-05 12:10 dynamic
    -rw-r--r-- 1 root  named  208 2005-04-28 19:56
    -rw-r--r-- 1 root  named  195 2005-04-28 19:56
    -rw-r--r-- 1 root  named  427 2005-04-28 19:56 named.broadcast
    -rw-r--r-- 1 root  root  2769 2007-06-21 01:54
    -rw-r--r-- 1 root  named  424 2005-04-28 19:56 named.ip6.local
    -rw-r--r-- 1 root  named  426 2005-04-28 19:56 named.local
    -rw-r--r-- 1 root  root  1195 2007-06-21 01:36 named.root
    -rw-r--r-- 1 root  named  427 2005-04-28 19:56
    -rw-r--r-- 1 named named  588 2007-06-21 01:54
    -rw-r--r-- 1 named named  778 2007-06-21 01:54
    drwxr-xr-x 2 named named 4096 2007-06-21 01:36 slave
    drwxrwx--- 2 root  named 4096 2004-07-27 16:57 slaves
    and the results from locate

    [[email protected] ~]# locate
    I hope this tell you more than it told me:(
  11. mlz

    mlz New Member

    Since it's looking for it in the /var/named/chroot/var/named/ directory, and it's not there, then I guess the problem is that it's not linked or at least where it's supposed to be. have you tried copying the file to /var/named/chroot/var/named ?

    # cp /home/admispconfig/ispconfig/web/multidoc/edit/ /var/named/chroot/var/named/
    And seeing if it loads? This isn't fixing the problem, but might get the DNS up until Till or Falko responds.
  12. Richard87

    Richard87 New Member

    Thank you very much, that did it:D
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    The directory /home/admispconfig/ispconfig/web/multidoc/edit/ is completely wrong and is used only for ISPConfig scripts and never bind configuration files. Please make sure that /var/named/chroot/var/named is world readable and then set the directory in ISPConfig under management > server > settings on the DNS tab as directory for your bind server.

Share This Page