Bind/named problem

Discussion in 'General' started by xarion, Aug 8, 2011.

  1. xarion

    xarion New Member

    Hey Guys, something seems to have stopped working.

    I can add my DNS entries and domains and it seems to be adding it to the database but for some reason it isnt adding it to the named.conf.local nor creating the pri.domain name file in /etc/bind/.

    What mechanism does ispconfig use to update those files? what permissions should the folders/files have?

    if i check my /var/log/apache2/error.log i get a bunch of these:

    [Mon Aug 08 13:00:18 2011] [error] [client *IP*] PHP Notice: Undefined index: ip in /usr/local/ispconfig/interface/web/dns/dns_wizard.php on line 127, referer: http://dns.name:8080/index.php
    [Mon Aug 08 13:00:18 2011] [error] [client *IP*] PHP Notice: Undefined index: ns1 in /usr/local/ispconfig/interface/web/dns/dns_wizard.php on line 127, referer: http://dns.name:8080/index.php
    [Mon Aug 08 13:00:18 2011] [error] [client *IP*] PHP Notice: Undefined index: ns2 in /usr/local/ispconfig/interface/web/dns/dns_wizard.php on line 127, referer: http://dns.name:8080/index.php
    [Mon Aug 08 13:00:18 2011] [error] [client *IP*] PHP Notice: Undefined index: email in /usr/local/ispconfig/interface/web/dns/dns_wizard.php on line 127, referer: http://dns.name:8080/index.php
    [Mon Aug 08 13:00:18 2011] [error] [client *IP*] PHP Notice: Undefined index: create in /usr/local/ispconfig/interface/web/dns/dns_wizard.php on line 131, referer: http://dns.name:8080/index.php

    Xarion
     
    Last edited: Aug 8, 2011
  2. till

    till Super Moderator

    Cronjob which runs once per minute.

    That does not matter as the cronjob runs as root user.

    These are just notices which can be ignored, They appear in the log because there is a wrong error level set in your php.ini file.

    Please take a look into the ispconfig monitor and check if the jobqueue is empty and if there are any errors in the syslog in the ispconfig monitor.
     
  3. xarion

    xarion New Member

    ok great, that was a super quick reply!

    everything seems to be working. would me changing my admin login to the interface have changed anything?
     
  4. till

    till Super Moderator

    No.

    Ok, so the jobqueue is empty? This means that you changes has been processed by the server script.

    Please check under system > server config if the path to the named conf directory and the named.conf.local file matches the paths on your server.

    If thats correct, then please post the output of this command:

    ls -la /usr/local/ispconfig/server/plugins-enabled/
     
  5. xarion

    xarion New Member

    Hi Till, what I meant to say is that everything is working back to normal as it was. Maybe I didnt wait long enough for the cron job when I posted my thread. Would the admin login to the interface have any influence on the running of the scripts? I presume not because as you said they run as a cron job.
     

Share This Page