Bind named - allow-transfer in .local instead of .options

Discussion in 'General' started by Enzo2424, Jul 29, 2016.

  1. Enzo2424

    Enzo2424 New Member

    Hi all
    I've encountered a problem on my Ubuntu server with ISPConfig3. I configured IPv6 (Ip per domain) and had problems transfering to secondary DNS server.

    It turns out that ISPConfig writes the allow-transfer to /etc/bind/named.conf.options, but not to /etc/bind/named.conf.local. Int hte /etc/bind/named.conf.local file, allow-transfer { none; }; whereas in the /etc/bind/named.conf.options file allow-transfer { IPv4;IPv6 }; is correctly written by ISPConfig.

    Unfortunately, /etc/bind/named.conf.local has priority over /etc/bind/named.conf.options, therefore my secondary DNS server wasn't getting the info.

    Maybe theres a way to have ISPConfig modify .local instead of .options, or both. ???

    My 2 cents, hope this will help.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The config is absolutely fine, the problem is that you missed to allow the transfer for the zone in the zone settings in ISPConfig.
  3. Enzo2424

    Enzo2424 New Member

    Thank you for your reply.
    However, I'm kinda lost here. Could you please give me an example, because I thought I correctly setup my DNS.
    I probably can't see the forest because of the tree in front of me.
    Thank you
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Add the IP address of the secondary DNS server in the "Allow zone transfer to" field of the DNS zone in ISPConfig and press the save button.
  5. Enzo2424

    Enzo2424 New Member

    OMG ! Thank you for the eye opener !

    However, I'm getting a message that there is already a record. Maybe because I manually added the info to .local.... ? I'll have to dig some more before coming back to you. But thank you for showing me the trail.
    Last edited: Sep 6, 2016

Share This Page