Bind Keeps Crashing, No Dns Resolution

Discussion in 'Server Operation' started by thebigtime, May 13, 2008.

  1. thebigtime

    thebigtime New Member


    This is my first time setting up a server so bare with me it its a real simple issue.

    1. I followed the perfect server guide for Ubuntu 8.04. For some reason the bind server crashed a few times in a couple days. I read somewhere that it could be apparmor but I purged it from the system and BIND still fails to start.

    I get the following error in the syslog.

    "server1 named:[6907] loading configuration: failure
    server1 named:[6907] exiting (due to fatal error)"

    2. When its online, its not resolving domains properly. If I type the IP it brings me to the shared IP notification of ISPConfig. But if I type in the domain name (which is pointing to my external IP address) its says server cannot be reached.

    The server is behind a router so I port forwarded HTTP, FTP, and DNS (TCP/UDP) to the LAN address.

    Any ideas to get this to work would be a great help.

  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/bind/named.conf? Do you get any errors when you restart BIND manually on the shell?

    Is the domain hosted on the not-working BIND, or on another DNS server (e.g. the DNS servers of your registrar)?
  3. thebigtime

    thebigtime New Member

    I have not touched the /etc/bind/named.conf file, so its just whats in it as default. Sorry I don't know how to copy and paste from the shell to windows.

    The domains are pointing to the malfunctioning BIND server (my external IP which is port forwarded to the IP of my Ubuntu on the LAN). But after I reinstalled BIND it has been working for the past day without stopping. ISPConfig says it online. The only thing is my domain is still not resolving. Its interesting because I log into ISPConfig from my external IP adress at port 81 and it shows up, but my domain that I have pointing to my external IP address is not resolving.

    If you wanted to host domains on your own server, what are the things that must be done? ex. pointing domain to IP adress, port forwading if behind router, and any BIND configurations.
  4. giganet

    giganet New Member

    Sorry I don't know how to copy and paste from the shell to windows. 
    Left click your mouse and drag to highlite the desired content, now use 'ctrl c' that should copy any content from CLI..
  5. falko

    falko Super Moderator ISPConfig Developer

    Can you post the domain name so that I can do a test?

Share This Page