.bin wont install - (tried everything?)

Discussion in 'Installation/Configuration' started by Tripytaka, Jul 21, 2009.

  1. Tripytaka

    Tripytaka New Member

    Hi All,

    I followed the tutorial “Perfect Ubuntu Server 9.04 ISPConfig3” and have set up my server to be an ISP and can access my website from the outside world. I have installed Joomla and in folders under Joomla Moodle, JFusion and Lime Survey. Everything is working perfect.

    The last part of my plan is causing me some grief. I want to install the Jasper Soft BI Suite. I have downloaded “jasperserver-3.5.0-linux-installer.bin” and it is sitting on my desktop. I have followed the jasper Server install pdf and successfully installed Apache Tomcat and Java.

    I have studied forums, websites and the great “How to install ANYTHING in Ubuntu”, but when I follow the instructions to install a .bin file the installation fails.


    I open the terminal and here's what I enter:

    cd Desktop
    ls
    sudo chmod +x jasperserver-3.5.0-linux-installer.bin
    ./jasperserver-3.5.0-linux-installer.bin



    Here is the result.


    myuser@myserver:~$ cd Desktop
    myuser@myserver:~/Desktop$ ls

    administration-console jasperserver-3.5.0-bin.zip
    jasperserver-3.5.0-linux-installer.bin
    BI Software
    How to install ANYTHING in Ubuntu.pdf

    myuser@myserver:~/Desktop$ sudo chmod +x jasperserver-3.5.0-linux-installer.bin

    myuser@myserver:~/Desktop$ ./jasperserver-3.5.0-linux-installer.bin
    bash: ./jasperserver-3.5.0-linux-installer.bin: No such file or directory

    myuser@myserver:~/Desktop$


    I have tried:

    chmod 755
    sudo ./
    sudo su (then enter password)

    Why is it telling me: No such file or directory” when the 'ls' command clearly shows the .bin sitting on my desktop? Is there a step I am missing?

    According to the tutorials and forums the above command should launch the .bin into action the same way double clicking an .exe does. But for me it does not.

    How do I get this thing to install. I am old-school .exe and this .bin process is causing me grief. I am familiar with .bin as a mountable image file, but I cannot burn an image with the jasperserver-3.5.0-linux-installer.bin

    One thing I thought of could be this part of the “Perfect Server” tutorial.

    9 Change The Default Shell

    /bin/sh is a symlink to /bin/dash, however we need /bin/bash, not /bin/dash. Therefore we do this:
    dpkg-reconfigure dash
    Install dash as /bin/sh? <-- No
    If you don't do this, the ISPConfig installation will fail.

    Can someone please point me in the right direction. I have tried to help myself by reading all the forums I can find, following the instructions, but this .bin has got me beat.

    I have tried all the install scripts I can find, and also different .bin files - i always get the same result. Maybe there is something within Ubuntu itself that is blocking the installation of a .bin.

    Please help. Any and all assistance is greatly appreciated.

    Regards -Tripytaka
     
  2. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -la ~/Desktop/
    ?
     
  3. Tripytaka

    Tripytaka New Member

    Thanks Falko

    Hi Falko,

    Thanks for the reply and for your fantastic tutorials.

    Here is the output:

    myuser@myserver:~$ ls -la ~/Desktop/
    total 1436
    drwxr-xr-x 9 administrator administrator 4096 2009-07-23 10:30 .
    drwx------ 36 administrator administrator 12288 2009-07-22 14:35 ..
    drwxr-xr-x 6 administrator administrator 4096 2009-07-21 23:22 administration-console
    drwxr-xr-x 7 root root 4096 2009-07-18 00:15 biserver-ce
    drwxr-xr-x 3 administrator administrator 4096 2009-07-21 23:22 biserver-ce-3.0.0-STABLE
    drwx------ 5 administrator administrator 4096 2009-07-23 10:30 BI Software
    drwxr-xr-x 3 administrator administrator 4096 2009-07-21 20:03 Clean Up
    -rwx------ 1 administrator administrator 1400285 2009-07-20 10:39 How to install ANYTHING in Ubuntu.pdf
    -rwx------ 1 administrator administrator 238603076 2009-07-17 02:47 jasperserver-3.5.0-linux-installer.bin
    drwxr-xr-x 6 administrator administrator 4096 2009-07-22 00:39 pentaho-demo
    drwxrwxr-x 3 administrator administrator 4096 2009-07-22 14:34 sun-java6-6-14
    -rw-r--r-- 1 administrator administrator 351 2009-07-21 18:37 Unsaved Document 17~
    myuser@myserver:~$

    Yesterday I had some issues with Java, so i reinstalled Java using a .bin file and it went perfectly.

    On the JasperForge forum there is also another person having problems with the Jasper .bin installer, so i think it might be crook.

    Regards -Tripytaka
     
  4. falko

    falko Super Moderator

    As administrator, run
    Code:
    chmod 755 ~/Desktop/jasperserver-3.5.0-linux-installer.bin
    Then try again.
     
  5. Tripytaka

    Tripytaka New Member

    Thanks for your assistance Falko.

    Here is the output.

    administrator@uiserve:~$ sudo su
    root@uiserve:/home/administrator# cd Desktop
    root@uiserve:/home/administrator/Desktop# ls
    jasperserver-3.5.0-bin
    jasperserver-3.5.0-linux-installer.bin
    jasperserver-3.5.0-windows-installer.exe
    root@uiserve:/home/administrator/Desktop# chmod 755 ~/Desktop/jasperserver-3.5.0-linux-installer.bin
    chmod: cannot access `/root/Desktop/jasperserver-3.5.0-linux-installer.bin': No such file or directory
    root@uiserve:/home/administrator/Desktop#

    Regards - Tripytaka
     
  6. Tripytaka

    Tripytaka New Member

    I have also reformatted my hdd and installed Ubuntu 8.04 64b.
     
  7. falko

    falko Super Moderator

    Strange. I have no idea what's going on... :(
     
  8. jdowns

    jdowns New Member

    I had the same problem. Running strace showed that it was a missing library. A little bit of research told me that jasperserver needs a 32 bit version of one of the libraries. I installed ia32-libs and it worked for me. I'm using ubuntu server 9.04 64 bit.
     

Share This Page