Billing Module Mail Error

Discussion in 'Plugins/Modules/Addons' started by harkman, Nov 17, 2016.

  1. harkman

    harkman New Member HowtoForge Supporter

    Hi.
    I'm still on ISPConfig 3.0.5 Billing Module Rev 10.
    I tried to use the Mail functions in the Billing Module the first time today but no mails were sent.
    My /var/log/mail.err shows:
    Code:
    Nov 17 23:42:01 ### postfix/sendmail[6056]: fatal: Recipient addresses must be specified on the command line or via the -t option
    Nov 17 23:42:01 ### postfix/postdrop[6057]: warning: stdin: unexpected EOF in data, record type 78 length 76
    Nov 17 23:42:01 ### postfix/postdrop[6057]: fatal: uid=5003: malformed input
    
    
    Any Idea why this is happening? How can I fix this?
     
    Last edited: Nov 17, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that the client has an email address set in his client details and that you have set an address for the company in the company settings of the billing module.
     
  3. harkman

    harkman New Member HowtoForge Supporter

    Hi Till.
    Both are properly set. Additionally I have a wrapper for sendmail, that can log some stuff and if using the wrapper I can see that To and From headers are properly set. But the mail cannot be sent with or without the wrapper.
    If I dump the whole mail to the logfile, I can see that german umlauts are stripped from the dump. Not sure if this has something to do with my issue.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The billing module uses the ispconfig mail library to send mail, the configuration of the ispconfig mail library is under system > interface config. If you set a hostname there (e.g. localhost), then the library will use smtp, if no hostname is set, then it will use the php mail() function. You can try to alter this setting to see if it makes a difference.
     
  5. harkman

    harkman New Member HowtoForge Supporter

    Thank you Till.
    I switched to SMTP and now Mails are sent. I'm fine with this.
     

Share This Page