Billing module and Paypal IPN

Discussion in 'Installation/Configuration' started by pititis, May 26, 2011.

  1. pititis

    pititis Member

    Hello,

    I'm using the ipnproxy.php suggested because my server use https and port 8080. In global settings is set to http://www.domain.de/ipnproxy.php but when a customer try to pay a invoice always get a redirection to http://domain.de:8080/billing/payments/pay.php?id=xxxxxxxxxx (without https) error 404. I have re-checked permissions and owner from the script. php5-curl is installed. I have changed urls to test but I get the redirection and 404, no matter I do I get the same redirection.

    Any idea?

    Cheers!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check that the URL to the ispconfig ipn page in the ipnproxy.php script is correct. You can do this by opening the the URL in the browser, you should get then a message like this "Direct access not allowed!".
     
  3. pititis

    pititis Member

    It work without problem Till.
     
  4. pititis

    pititis Member

    ...Nothing to do.

    When I click in "pay now" I always get redirection to:

    http://xxx.com:8080/billing/payments/pay.php?id=xxxxxxxxxxxxxxxxxxxxxxxxxxxxx

    Code:
    
    Bad Request
    
    Your browser sent a request that this server could not understand.
    Reason: You're speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL, please.
    
    Hint: https://server.xxx.com:8080/
    
    
    Changing manually the http for https works. My ispconfig is on port 8080 and I use ssl certificate (self-signed).

    Is the get_ispconfig_url function working correctly??:confused:

    Cheers!
     
  5. pititis

    pititis Member

    Till I need you!

    No matter you set in the paypal ipn field doesn't works but the value is in the "invoice_settings" table.

    :(
     

Share This Page