Big problem with apache2 on Ubuntu

Discussion in 'Installation/Configuration' started by piratta, Jan 18, 2006.

  1. piratta

    piratta New Member

    I install ispconfig in Ubuntu (Server) whit the tutorial of howtoforge.
    All works fine, but apache2 not run.
    When i start manually apache2 the pront say me:

    root@xxxx:~# /etc/init.d/apache2 start
    * Starting web server (Apache2)... Syntax error on line 411 of /etc/apache2/apache2.conf:
    Multiple <Directory> arguments not (yet) supported.
    [fail]

    I look the config file of apache and i don't understand.

    #######################################
    ######### APACHE2.CONF##################
    ####################################

    LINE 340 # To use CGI scripts outside /cgi-bin/:
    #
    #AddHandler cgi-script .cgi

    # To use server-parsed HTML files
    #
    <FilesMatch "\.shtml(\..+)?$">
    ##ISPConfig INSTALL## SetOutputFilter INCLUDES
    </FilesMatch>

    # If you wish to use server-parsed imagemap files, use
    #
    #AddHandler imap-file map

    BrowserMatch "Mozilla/2" nokeepalive
    BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
    BrowserMatch "RealPlayer 4\.0" force-response-1.0
    BrowserMatch "Java/1\.0" force-response-1.0
    BrowserMatch "JDK/1\.0" force-response-1.0

    #
    # The following directive disables redirects on non-GET requests for
    # a directory that does not include the trailing slash. This fixes a
    # problem with Microsoft WebFolders which does not appropriately handle
    # redirects for folders with DAV methods.
    #

    BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
    BrowserMatch "^WebDrive" redirect-carefully
    BrowserMatch "^gnome-vfs" redirect-carefully
    BrowserMatch "^WebDAVFS/1.[012]" redirect-carefully

    # Allow server status reports, with the URL of http://servername/server-status
    # Change the ".your_domain.com" to match your domain to enable.
    #
    #<Location /server-status>
    # SetHandler server-status
    # Order deny,allow
    # Deny from all
    # Allow from .your_domain.com
    #</Location>

    # Allow remote server configuration reports, with the URL of
    # http://servername/server-info (requires that mod_info.c be loaded).
    # Change the ".your_domain.com" to match your domain to enable.
    #
    #<Location /server-info>
    # SetHandler server-info
    # Order deny,allow
    # Deny from all
    # Allow from .your_domain.com
    #</Location>

    # Include the virtual host configurations:
    Include /etc/apache2/sites-enabled/[^.#]*

    <directory /var/www/sharedip>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <files ~ "^\.ht">
    Deny from all
    </files>
    </directory>

    ###############ispconfig_log###############
    LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

    LINE 411 <directory /var/www as Web-Root/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <files ~ "^\.ht">
    Deny from all
    </files>
    </directory>

    <directory /var/www as Web-Root/*/user/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <files ~ "^\.ht">
    Deny from all
    </files>
    </directory>

    <directory /var/www as Web-Root/*/cgi-bin>
    Options ExecCGI -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <files ~ "^\.ht">
    Deny from all
    </files>
    </directory>

    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf

    ###################################
    ######### END #####################
    ################################

    SORRY for my bad english & thank you for your help.


    piratta
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please replace these line:

    <directory /var/www as Web-Root/*/web>

    with:

    <directory /var/www/*/web>

    and:

    <directory /var/www as Web-Root/*/user/*/web>

    with:

    <directory /var/www/*/user/*/web>

    and:

    <directory /var/www as Web-Root/*/cgi-bin>

    with:

    <directory /var/www/*/cgi-bin>
     
  3. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    ... and restart Apache afterwards.

    When you installed ISPConfig, and the installer asked you for the docroot, did you enter "/var/www as Web-Root"? Should have been "/var/www" instead.
     

Share This Page