BIG! mysql-PHPmyadmin problem

Discussion in 'Installation/Configuration' started by flevoict, Sep 14, 2009.

  1. flevoict

    flevoict New Member

    Dear all,

    I hope somebody can help me because I have a big problem. I can't login anymore to the PHPmyadmin of my main ispconfig server.

    All the servers are setup with

    When I added the second server to het ISPConfig network I run the following commands on the phpmyadmin:
    update user set Host='second server' where user='root';

    update db set Host='second server' where Db='mysql';

    After this I could add the ISPConfig installation through the expert mode.

    Today I wan't to add the third server and now I can't login to PHPmyadmin. It gives me the error:
    #1045 - Access denied for user 'root'@'localhost' (using password: YES)

    And in shell mode:
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

    And now the funniest thing, if i connect on the second server through shell mode to the first server I have access.

    I know for sure that the passwords are correct so that isn't the problem. I think that with adding the users for the second server the localhost login is disabled/changed/deleted or something.

    I hope someone can help me with this issue.

    And if there is anybody who can easily explain me how to give a server access to the main database for the expert setup it would be appreciated.

    Thnx in advance,

  2. edge

    edge Active Member Moderator

  3. flevoict

    flevoict New Member

    I already tried this. It didn't help.

    The option is already on cookie, if I change it to config I just get an access denied message.
  4. flevoict

    flevoict New Member

    Fixed it!!!

    - I restarted the mysql server like this so I could login:
    Stop the MySQL server by using either of the following command
    #/etc/init.d/mysql stop
    Now you need to Start MySQL server without password
    # mysqld_safe --skip-grant-tables &

    - Now I could login again in phpmyadmin and I added a new localhost root user (this one was lost).

    - Then I ran the following commands
    Now you need to Stop MySQL Server using the following command
    # /etc/init.d/mysql stop

    - Test Your New Mysql root password
    First you need to start mysql server using the following command
    # /etc/init.d/mysql start
    # mysql -u root -p
    Now it will prompt for root password and enter your new root password
  5. ArchiMark

    ArchiMark New Member

    So glad that I found your post, flevoict.....have read post upon post upon post around the net looking for info like yours....

    I tried your suggestions and the good news is that after I did the first part above I was finally able to login to phpmyadmin and see the page where you can make adjustments, etc....

    However, after I tried adding a new user there, and clicked the 'Go' button (think that is what is was called...) to save the new user, I got error message that it could not save new user as '-skip-grant-tables' was in, seems like a 'Catch 22' situation, where if I restart MySQL server again, then I can't login to create new user....

    Am I missing something here?

    Do you or anyone else have any suggestions as to how get over this vicious circle I am in where either I can't login to phpmyadmin or if I can login via flevoict's suggestions, then I can't actually save any changes I make....

    Thanks for any and all help with this....have spent hours trying to get this working right...

    Happy Holidays,


Share This Page