big maill mess

Discussion in 'Server Operation' started by savago, Sep 24, 2008.

  1. savago

    savago Member

    When try to send from any domain between same users in this domain i get "
    "mail for x.x.x loops back to myself". When send from otrer mailserver i get "
    NOQUEUE: reject: RCPT from x.x.x ... Relay access denied;.
    This is centos 5.2 perfect setup.

    hostname is server1.h.y.z

    hostname in /etc/hosts and /etc/sysconfig/network is same one. This hostname is in /etc/postfix/main.cf (myhostname= server1.h.y.z) , mydestinatin is mydestination = $myhostname, localhost.$mydomain, localhost, server1.x.y.z.

    local-host-names are:
    localhost
    server1.x.y.z
    localhost.x.y.z
    localhost.x.y.z
    localhost.localdomain
    ....


    virtusertable:

    i see one acc (domain name of ns.x.y.z) with this syntax:
    [email protected] web15_user
    [email protected] web15_user
    (there no record for this domain [email protected], only [email protected]in)


    And others with this syntax:
    [email protected] web25_user
    [email protected] web25_user
    [email protected] web25_user
    ...


    I cant understand what is reason for this error.
     
    Last edited: Sep 25, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    Please add x.x.x to the mydestination line in /etc/postfix/main.cf and restart Postfix.
     
  3. savago

    savago Member

    Ok, x.x.x was added



    [[email protected] postfix]# /etc/init.d/postfix restart
    Shutting down postfix: [ OK ]
    Starting postfix: [ OK ]
    [[email protected] postfix]#

    [[email protected] postfix]# tail -f /var/log/maillog

    stopping the Postfix mail system
    Sep 25 18:10:43 server1 postfix/master[13291]: terminating on signal 15
    Sep 25 18:10:43 server1 sendmail[13364]: alias database /etc/aliases rebuilt by root
    Sep 25 18:10:43 server1 sendmail[13364]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
    Sep 25 18:10:44 server1 postfix/postfix-script: starting the Postfix mail system
    Sep 25 18:10:44 server1 postfix/master[13410]: daemon started -- version 2.3.3, configuration /etc/postfix

    (from user1 to user2)

    Sep 25 18:12:32 server1 postfix/cleanup[13464]: DAAB62868177: message-id=<[email protected]>
    Sep 25 18:12:32 server1 postfix/qmgr[13413]: DAAB62868177: from=<[email protected]>, size=1413, nrcpt=1 (queue active)
    Sep 25 18:12:32 server1 postfix/local[13481]: DAAB62868177: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.31, delays=0.26/0/0/0.04, dsn=2.0.0, status=sent (delivered to maildir)
    Sep 25 18:12:32 server1 postfix/qmgr[13413]: DAAB62868177: removed

    (from user1 to user3)

    Sep 25 18:15:12 server1 postfix/smtpd[13566]: NOQUEUE: reject: RCPT from ip-adress.com]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected],y,z> proto=ESMTP helo=<st3>
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Is [email protected] listed in /etc/postfix/virtusertable?
    Is x.y.z listed in /etc/postfix/local-host-names?
     
  5. savago

    savago Member

    There is records for user3 in etc/postfix/virtusertable and x.y.z is listed in /etc/postfix/local-host-names, but with prefix [email protected], www.x.y.z only. Records without @www. for this domain (x.y.z) do not exist at all,a and maybe this is problem.
     
    Last edited: Sep 26, 2008
  6. falko

    falko Super Moderator ISPConfig Developer

    Please go to the Co-Domains tab of that web site in ISPConfig and create the Co-Domain x.y.z (with an empty hostname!).
     

Share This Page