Big FTP issue, pleace help pleace!

Discussion in 'Installation/Configuration' started by shoevring, Oct 2, 2010.

  1. shoevring

    shoevring New Member


    Lots of my customers is very angry about our solution at this moment.

    Then the customer uploading some files to the server, they can't delete some folders some times.. Its a problem..

    Folder permissions is the same for the other folders they can delete..

    The error message is:" The Directory is not empty ", and then the user is trying to view into the folder, it is empty..

    I going into the server on shell as root, and delete the folder without a problem.

    Iam running the newest published version of ispconfig 3.

    Pleace reply soon, thanks!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Never seen this error. The problem might be realted to the ftp daemon, the firewall or the ftp client. You should enable debugging in the ftp daemon to see whats happening, disable temporarily afirewall if you use one and try to use a different FTP client.
  3. shoevring

    shoevring New Member

    We have firewall of front in our network, so we do not have the "software based firewall".

    FTP, we have tried more than 4 diff. clients and its the same..

    I have tryed to use this command: echo "yes" > /etc/pure-ftpd/conf/DisplayDotFiles

    Then the ftp client can see .htaccess file in the folder and then the client CAN delete the folder without any problems.

    Can this problem have anything with hiddenfiles?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ahh, ok. So there is no problem, just a misunderstanding. Folders can never be deleted by FTP when there is a file inside. it is the same as if you use the rmdir command on the shell. .htacesss is a normal file and it prevents the deletion of a folder like any other file. If The FTP Daemon on your server did not show hidden files, then he was not able to delete the file which also prevented that he deletes the folder.
  5. shoevring

    shoevring New Member

    Ok thanks! Iam going to use this command on all my webservers..

Share This Page