BETA2: PHP-FPM socket and TCP gets mixed up

Discussion in 'Developers' Forum' started by gkovacs, Jul 9, 2016.

  1. gkovacs

    gkovacs Member

    After upgrading ISPConfig to 3.1 beta2, I have turned on "Let's Encrypt SSL" for a site. After waiting a minute or two, the site always had this option disabled. So I tried this a couple of times, until...

    I detected that PHP is not running on this site anymore: regardless of site option "Use socket for PHP-FPM" is set to YES, /etc/php5/fpm/pool.d/web1.conf will always have listen= in it, even though the corresponding Apache vhost (correctly) tries to use a socket for PHP-FPM. This is client1/web1, all other sites are fine, using socket at all places.
    Last edited: Jul 11, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linux Distribution?
  3. gkovacs

    gkovacs Member

    It's an OpenVZ container running Debian 7 with Apache 2.2 worker and PHP-FPM 5.5 from DotDeb. Install based on Debian Wheezy Perfect Server.

Share This Page