Best perfect setup howto?

Discussion in 'HOWTO-Related Questions' started by KenKnight, Jan 30, 2007.

  1. KenKnight

    KenKnight Member

    Ok folks,

    I've spent the last several days trying to get a stink'n debian system up and running so I can transfer my existing debian sarge virtual sites to the new system.

    The problem is this; Everything goes absolutely wonderful until the minute I try to upgrade mysql or php to ver 5. Then everything goes to pot!!!

    Each time mysql-server-5.0 tries to install it says it has to remove a running kernel and replace it with the exact same version??? The only way that I've found to get it going is to answer "yes" to this prompt. At which point everything works great until you reboot and then guess what... you're hosed. All you get is a grub prompt.

    I'm finding absolutely nothing on repair grub or whatever.

    Any suggestions would be incredibly appreciated as I'm tired of fooling with this thing.

    Is there a better and more stable setup than the debian sarge setup that has php5 / mysql5?

    Thanks,
    Ken
     
    Last edited: Jan 30, 2007
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    I had no problems with MySQL 5 and PHP 4 or 5 on Ubuntu 6.10 Efty Edge. I have split php4 and php5 on different systems though. So no mix between the two php versions. But php5 and MySQL 5 are installed without a hitch (following major parts of the perfect setups on howtoforge)
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Ken, which mysql5 and php5 packages did you use? The packages from dotdeb.org are working perfectly. Dont try to use packages from the unstable / testing branch of debian, this breaks the setup in many cases!
     
  4. KenKnight

    KenKnight Member

    Hi all,

    Martin; I've downloaded a vmware appliance of this version so I'll run through the setup on it to see what happens.

    Till; I'm not sure if this is what corrected it, but I first installed a 686 kernel image and then commented out the unstable dotdeb while leaving the rest. I was able to successfully get the mysql5 server install without a fuss and next started on the php5. While I've got php5 installed and showing with a phpinfo(), the problem now is that when I try to use a mysql_connect() I get an "undefined function" which I think means the php client is not correct?? I've install php5-mysql and almost all the other php5 modules that show up in apt-cache search php5.

    Any suggestions?

    EDIT:: I got it. I edited the php.ini and made sure the mysql.so was not commented and then restart apache2. Its now working.

    Thanks,
    Ken
     
    Last edited: Jan 30, 2007

Share This Page