Bcc on SMTP Message

Discussion in 'Tips/Tricks/Mods' started by msource, Apr 14, 2009.

  1. msource

    msource New Member

    Good afternoon,

    I wonder if you can put a Bcc when sending an email via SMTP from Outlook directly on the server without the user having knowledge.

    Or if is another way to do this.

    Thank you,
    Marcos Pinto
  2. dipeshmehta

    dipeshmehta New Member

    you can use always_bcc feature of postfix.
  3. msource

    msource New Member

    How can i do that?

    Could you please help me?
  4. dipeshmehta

    dipeshmehta New Member


    if you want to have bcc of all messages passes through postfix, then you may add line
    always_bcc = [email protected]
    into your /etc/postfix/main.cf file. This options sends bcc of all messages i.e. incoming as well as outgoing, to [email protected]

    Similarly, if you want to tweak the setting, you may use sender_bcc_maps and recipient_bcc_maps feature.

    For example: if you want bcc of all outgoing message from a domain1.com, you may create a file with any name in /etc/postfix with something like this:
    then run
    add following line to /etc/postfix/main.cf
    The same could be done with recipient_bcc_maps.

    You may find details at http://www.postfix.org/postconf.5.html

    Hope this helps, tell me in any further clarification/guidance in the matter required.

  5. msource

    msource New Member


    Thank you for you fast replay, and very explaning one.

    I create a file in /etc/postfix/bcc_maps with the following:

    [email protected] another_sender@another_domain.tld

    And add the sender_bcc_maps = hash:/etc/postfix/filename in the main.cf file of postfix.

    With this config, i'm able do copy all the e-mail's send from [email protected] to another_sender@another_domain.tld, correct?

    Did i do this right?
    Tanks a lot for your help.

    The ISPConfig project is one of the best Open-Source projects in all aspects.
    God whork guys.
  6. dipeshmehta

    dipeshmehta New Member

    I am sorry, I was not so clear in writing. you should write
    into the main.cf.

    and please do not forget to run postmap command and then postfix restart


Share This Page