Basic setup for ISPConfig 3 and dns

Discussion in 'Installation/Configuration' started by jopa123, Sep 22, 2010.

  1. jopa123

    jopa123 New Member

    I'm relatively new here, so excuse me if my questions are very rudimentary.

    I have completed my server using the The Perfect Server - Ubuntu 9.04 [ISPConfig 3]. The server is in my home which has a single dynamic IP address. The address changes rarely but it does change (maybe 3 times a year at the most)

    My problem: I need to have two dns servers (with two separate IP addresses) at the registrar where most of my domains are located. The rest of my domains are at Godaddy and I believe the same is true - need two dns servers.

    Here are my questions:

    1. What is the easiest and most efficient setup to handle DNS in this situation?

    2. Should I use DyDNS? Do I use it for all dns or just as a secondary dns? Is the service that I need free or is it something they charge for? Does DyDNS actually give me an IP address that I can enter at the registrar for each virtual DNS server or is it a sub-domain?

    3. If I use DyDns, do I need to "turn off" the DNS in ISPConfig or change other settings somewhere? Do I leave the zone empty?

    4. If I don't use DyDNS, what is the process for changing the IP address in ISPConfig when it does change?

    Thanks in advance
  2. falko

    falko Super Moderator ISPConfig Developer

    In your case where you just have one public IP which changes from time to time, I suggest that you use your registrar's nameservers. I think most registrars offer DNS services now for free.
  3. jopa123

    jopa123 New Member



    Thanks. I'm working with the options available at my registrar.

    Do I have to turn off DNS on my server, or anything?
  4. falko

    falko Super Moderator ISPConfig Developer

    IF you don't use it, turn it off to save server resources. :)
  5. jopa123

    jopa123 New Member

    Getting default Apache page


    Got the dns working now, but all my sites give the default Apache page that says simply "It Works"

    I've tried it on several sites. Where's my issue?

    Thanks again.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Add the internal IP address under system > server IP.
    2) Select this IP address in the website settings of the websites that you created.
    3) select auto subdomain: www in the website settings.
  7. jopa123

    jopa123 New Member

    ftp to wrong folder

    I think I'm almost there, thanks to you guys. I'm now getting the ISPconfig "Welcome to Your Website" default page.

    Here's the latest issue(s).

    I created an ftp login for myself and attempted to upload the files for my site. I still got the default page. I went digging around in the files and I found that in my directory (/var/www/clients/client1) there were three other directories - web1, web3, and

    It appears that my files were uploaded to the web3 directory instead of the directory.

    Where did I mess up?

    Second question. My ftp login has the word "default" in front of the username. Is there a way to get rid of this?

    Third question. How do I create a user login that will allow someone else to login to a control panel that is specific to their website, not a "master" type control panel? Or is this possible? And what url would they use to log in?

    I really have tried to research these questions before bothering you with them. But I've had no luck.

    I truly appreciate your help.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please delete the index.html file in the web folder of the website. It has to be deleted when you upload a new index.php or index.htm file. Also make sure that you uploaded your files into the web subfolder.

    Regarding the FTP username prefix, this is configured under system > Interface config. You should remove the prefix only if this server has no clients, as FTP usernames have to unique for the whole server and the prefix enforces that.
  9. jopa123

    jopa123 New Member


    Boy do I feel stupid. I just assumed that Dreamweaver overwrote that file with mine. Rookie mistake.

Share This Page